8.х массив

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем auricomwxl, 17 фев 2010.

  1. TopicStarter Overlay
    auricomwxl
    Offline

    auricomwxl

    Регистрация:
    4 янв 2010
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Привет!
    Не могу отобразить наименование элементов в окне сообщений!
    Получиться должно:

    Гоги
    Шмоги
    Иванов
    Петров
    Сидоров

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    перем Мас, эл;    
    Мас = Новый Массив(1); 
    Мас[0]="Гоги",Мас[1]="Шмоги";  
    Мас.Добавить("Иванов"); 
    Мас.Добавить("Петров"); 
    Мас.Добавить("Сидоров");
    Для Каждого эл Из Мас Цикл 
    Сообщить(Мас);  
    КонецЦикла;
    КонецПроцедуры
    
    
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.580
    Симпатии:
    717
    Баллы:
    204
    нужно делать Сообщить(Эл)
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Массив = Новый Массив();
    Массив.Добавить("Гоги");
    Массив.Добавить("Шмоги");
    Массив.Добавить("Иванов"); 
    Массив.Добавить("Петров"); 
    Массив.Добавить("Сидоров");
    i=0;
    Пока i<Массив.Количество() Цикл
    Сообщить(Строка(Массив[i]));
    i=i+1;
    КонецЦикла;
    
    КонецПроцедуры
    

Поделиться этой страницей