8.х Макет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем lsd, 17 авг 2009.

  1. TopicStarter Overlay
    lsd
    Offline

    lsd

    Регистрация:
    30 июл 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Подскажите делаю печатную форму . В ней есть поле Номенклатура . Оно берет данные из запроса . Но при выводе секции . Номенклатура выводит только одно значение . Хотя запрос отдает их несколько . Я так понимаю нужно дописать цикл . Вот тока что-то не пойму где

    Код:
    ТабДок = Новый ТабличныйДокумент;
    Макет = Документы.ЗаявкаНаТранспорт.ПолучитьМакет("Печать");
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(Область);
    // Шапка
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ЭтотОбъект);
    ТабДок.Вывести(Шапка);
    
    
    Секция = Макет.ПолучитьОбласть("Товар");
    Секция.Параметры.Номенклатура = Номенклатура;
    Секция.Параметры.Количество = Количество;
    Секция.Параметры.Цена=Цена;
    Секция.Параметры.Сумма=Сумма;
    
    ТабДок.Вывести(Секция);
    
    
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    //}}_КОНСТРУКТОР_ПЕЧАТИ_ЭЛЕМЕНТ
    КонецЕсли;
    КонецПроцедуры
    
    
  2. wiranata
    Offline

    wiranata Опытный в 1С

    Регистрация:
    21 янв 2009
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    По логике там где ты формируеш табличную часть отчета (в области "Товар")
  3. mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Код:
      Секция = Макет.ПолучитьОбласть("Товар");
    
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    Секция.Параметры.Номенклатура = Номенклатура;
    Секция.Параметры.Количество = Количество;
    Секция.Параметры.Цена=Цена;
    Секция.Параметры.Сумма=Сумма;
    
    ТабДок.Вывести(Секция);
    КонецЦикла;
    
  4. TopicStarter Overlay
    lsd
    Offline

    lsd

    Регистрация:
    30 июл 2009
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    спасибо :) вроде разобрался :unsure:

Поделиться этой страницей