8.х Макет печати ОС

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем dfx, 5 май 2010.

  1. TopicStarter Overlay
    dfx
    Offline

    dfx

    Регистрация:
    26 апр 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Вопрос.

    1С 8.1.15.14 БП 1.6.24.7

    Необходимо распечатать список ОС помеченных как ОсновныеСредства.Автотранспорт = ИСТИНА.
    В конфигураторе с помощью конструктора печатной формы создал макет и процедуру печати, но она, естественно, печатает все что есть в справочнике ОС. Какое условие надо задать чтобы печаталось только то, что помечено как Автотранспорт = ИСТИНА.

    код
    Код:
    Процедура ПечатьТС(Элемент)
    //{{_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК(ПечатьТС)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    ТабДок = Новый ТабличныйДокумент;
    Макет = Справочники.ОсновныеСредства.ПолучитьМакет("ПечатьТС");
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(Область);
    // Шапка
    Область = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Область);
    Выборка = Справочники.ОсновныеСредства.ВыбратьИерархически();
    Группа = Макет.ПолучитьОбласть("Группа");
    Элемент = Макет.ПолучитьОбласть("Элемент");
    Пока Выборка.Следующий() Цикл
    Если Выборка.ЭтоГруппа Тогда
    Группа.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Группа);
    Иначе
    Элемент.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Элемент);
    КонецЕсли;
    КонецЦикла;
    
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    //}}_КОНСТРУКТОР_ПЕЧАТИ_СПИСОК
    КонецПроцедуры
    
    
    
  2. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    Автотранспорт -это группа ОС?

    У ОС есть реквизит ГруппаОС, которая ссылается на перечисления Группы ОС. вот Вам скорее свего и надо

    Если Выборка.ГруппаОС=Перечисления.ГруппыОС.ТранспортныеСредства Тогда

    Или у Вас автотранспорт это просто папочка с справочнике ОС?
  3. TopicStarter Overlay
    dfx
    Offline

    dfx

    Регистрация:
    26 апр 2010
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Решил не гемороится с разработкой печатной формы с размещением кнопки печати, а создать отчет.

    Воспользовался схемой компоновки данных. Взял Регистр Сведений - РегистрацияТранспортныхСредствСрезПоследних
    Код:
    ВЫБРАТЬ
    РегистрацияТранспортныхСредствСрезПоследних.Марка,
    РегистрацияТранспортныхСредствСрезПоследних.РегистрационныйЗнак,
    РегистрацияТранспортныхСредствСрезПоследних.ОсновноеСредство.ДатаВыпуска,
    РегистрацияТранспортныхСредствСрезПоследних.ОсновноеСредство.ЗаводскойНомер,
    РегистрацияТранспортныхСредствСрезПоследних.ОсновноеСредство.Изготовитель,
    РегистрацияТранспортныхСредствСрезПоследних.ОсновноеСредство.НомерПаспорта,
    РегистрацияТранспортныхСредствСрезПоследних.ОсновноеСредство.Наименование,
    ХозрасчетныйОстатки.СуммаОстатокКт КАК СуммаОстатокКт
    ИЗ
    РегистрСведений.РегистрацияТранспортныхСредств.СрезПоследних КАК РегистрацияТранспортныхСредствСрезПоследних,
    РегистрБухгалтерии.Хозрасчетный.Остатки КАК ХозрасчетныйОстатки
    
    Вопрос. как правильно сформировать запрос, чтобы по каждому транспортному средству видеть остаточную стоимость ?

Поделиться этой страницей