8.х Макет и вывод отчета

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ARTMARI, 3 мар 2009.

  1. TopicStarter Overlay
    ARTMARI
    Offline

    ARTMARI

    Регистрация:
    3 мар 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста найти ошибку. На рис макет1 , отчет который должен быть получен.Проблема с выводом итогов.Надо, чтобы выводились итоги по группировке сотрудников, т.е например ИТОГ по топливу для Васина по всему приходящему через него топливу, а у меня выводит отдельно для каждой строчки итог.В чем ошибка?Может быть в макете, который на рис макет или в запросе?



    Код:
    Запрос = Новый Запрос("ВЫБРАТЬ
    |    ХозрасчетныйДвиженияССубконто.СчетДт КАК СчетДт,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт1 КАК Номенклатура,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт1 КАК ФизическоеЛицо,
    |    СУММА(ХозрасчетныйДвиженияССубконто.Сумма) КАК Сумма,
    |    ХозрасчетныйДвиженияССубконто.Регистратор КАК Документ,
    |    СУММА(ХозрасчетныйДвиженияССубконто.КоличествоДт) КАК Количество,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код КАК ТабельныйНомер,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |    ХозрасчетныйДвиженияССубконто.СчетДт.Код КАК Код,
    |    ХозрасчетныйДвиженияССубконто.СчетДт.Наименование КАК ИмяСчета
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.ДвиженияССубконто(
    |            &НачПериода,
    |            &КонПериода,
    |            СчетДт В ИЕРАРХИИ (&Счет10_3)
    |                И СчетКт В ИЕРАРХИИ (&Счет71_1)) КАК ХозрасчетныйДвиженияССубконто
    |
    |СГРУППИРОВАТЬ ПО
    |    ХозрасчетныйДвиженияССубконто.СчетДт,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт1,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт1,
    |    ХозрасчетныйДвиженияССубконто.Регистратор,
    |    ХозрасчетныйДвиженияССубконто.СубконтоКт1.Код,
    |    ХозрасчетныйДвиженияССубконто.СубконтоДт1.БазоваяЕдиницаИзмерения
    |ИТОГИ
    |    СУММА(Сумма),
    |    СУММА(Количество)
    |ПО
    |    ОБЩИЕ,
    |    СчетДт,
    |    Номенклатура");
    
    
    Запрос.Параметры.Вставить("НачПериода", НачПериода);
    Запрос.Параметры.Вставить("КонПериода", КонПериода);
    Запрос.Параметры.Вставить("Счет10_3", ПланыСчетов.Хозрасчетный.НайтиПоКоду("10.03"));
    Запрос.Параметры.Вставить("Счет71_1", ПланыСчетов.Хозрасчетный.НайтиПоКоду("71.01"));
    
    Результат = Запрос.Выполнить();
    
    Если Результат.Пустой() Тогда
    Возврат;
    КонецЕсли;
    
    ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;   
    Макет = ПолучитьМакет("МакетТопливо");
    ОбластьШапкаТаблицы= Макет.ПолучитьОбласть("Шапка");
    ОбластьСчетДт=Макет.ПолучитьОбласть("СчетДт");
    ОбластьДетали= Макет.ПолучитьОбласть("Детали");
    ОбластьИтоги= Макет.ПолучитьОбласть("ОбщиеИтоги");
    ОбластьИтогиПоГруппировке= Макет.ПолучитьОбласть("ИтогПоГруппировке");
    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();
    ВыборкаОбщие = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока ВыборкаОбщие.Следующий() Цикл
    ВыборкаСчет = ВыборкаОбщие.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока ВыборкаСчет.Следующий() Цикл
    ВыборкаНоменклатура = ВыборкаСчет.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    Пока ВыборкаНоменклатура.Следующий() Цикл
    Выборка = ВыборкаНоменклатура.Выбрать();
    ОбластьСчетДт.Параметры.Заполнить(ВыборкаНоменклатура);
    ТабДок.Вывести(ОбластьСчетДт);
    Пока Выборка.Следующий() Цикл
    ОбластьДетали.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(ОбластьДетали);
    ОбластьИтогиПоГруппировке.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(ОбластьИтогиПоГруппировке);
    
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    КонецЦикла;
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    
    Посмотреть вложение 1646 Посмотреть вложение 1647

    Вложения:

    • макет1.jpg
      макет1.jpg
      Размер файла:
      71,6 КБ
      Просмотров:
      52
    • макет.bmp
      Размер файла:
      548,6 КБ
      Просмотров:
      35
  2. 1Cnica
    Offline

    1Cnica Опытный в 1С

    Регистрация:
    13 фев 2009
    Сообщения:
    416
    Симпатии:
    0
    Баллы:
    26
    а вы с помощью конструктора выходных форм делаете?

    а ну да видно по тексту что с конструктором...

    попробуйте сначала посмотреть на таблицу значений с результатом запроса.
    для этого замените
    Код:
    Результат = Запрос.Выполнить();
    
    на

    Код:
    Результат = Запрос.Выполнить().Выгрузить();
    
    и поставьте тут точку останова.

Поделиться этой страницей