8.х ЛЗК

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Vovan27, 21 июл 2008.

  1. Melanto
    Offline

    Melanto Опытный в 1С

    Регистрация:
    28 ноя 2007
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    мне кажется (пробовать некогда, прости), что если перечислить их через запятую после номенклатуры, то будет нормально.
    В БП есть такие строчки:

    Код:
    ВыручкаПоТоварам.Свернуть("Номенклатура, СчетДоходовНУ, СубконтоНУ","СуммаБезНДС,Количество");
    
  2. TopicStarter Overlay
    Vovan27
    Offline

    Vovan27

    Регистрация:
    17 июл 2008
    Сообщения:
    45
    Симпатии:
    0
    Баллы:
    1
    Если ставлю так:

    НовДокумент.Номенклатура.Свернуть("Номенклатура,Ед,Коэффициент","Количество");

    то несворачивает ничего, Ед у меня л. (литры)
  3. TopicStarter Overlay
    Vovan27
    Offline

    Vovan27

    Регистрация:
    17 июл 2008
    Сообщения:
    45
    Симпатии:
    0
    Баллы:
    1
    Порылся немного в хелпе вот что получилось:
    Код:
    Процедура ЗаполнитьПеремещение(Элемент)
    ТекСтрока=ЭлементыФормы.Номенклатура.ТекущиеДанные;
    НовДокумент = Документы.Перемещение.СоздатьДокумент();
    НовДокумент.Заполнить(ссылка);
    НовДокумент.Автор = Автор;
    НовДокумент.Дата = Дата;
    НовДокумент.Склад = Склад;
    НовДокумент.Отправитель = Склад;
    НовДокумент.Организация = Организация;
    НовДокумент.Получатель = Заправщик;
    НовДокумент.НовыйСклад = Заправщик;
    НовДокумент.ПоследняяКорректировка = ПоследняяКорректировка;
    НовДокумент.Примечание = "Заполнено по Заявке на топливо № " + Номер + " от " + Дата;
    Для каждого ТекСтрока из Номенклатура Цикл
    Если ТекСтрока.Заправщик=Истина Тогда
    НоваяСтрока = НовДокумент.Номенклатура.Найти(ТекСтрока.ВидТоплива,"Номенклатура");
    Если НоваяСтрока = неопределено Тогда
    НоваяСтрока = НовДокумент.Номенклатура.Добавить();
    НоваяСтрока.Количество = 0;
    КонецЕсли;
    НоваяСтрока.Номенклатура = ТекСтрока.ВидТоплива;
    НоваяСтрока.НоменклатураСтало = ТекСтрока.ВидТоплива;
    НоваяСтрока.Ед = ТекСтрока.Ед;
    НоваяСтрока.Количество = НоваяСтрока.Количество+ТекСтрока.Заявлено;
    НоваяСтрока.Склад = ТекСтрока.Транспорт;
    НоваяСтрока.Коэффициент = 1;
    НовДокумент.Номенклатура.Свернуть("Номенклатура,Ед,Коэффициент","Количество");
    Иначе Продолжить;
    КонецЕсли;
    КонецЦикла; 
    ФормаНовыйДокумент=НовДокумент.ПолучитьФорму(,ЭтаФорма);
    ФормаНовыйДокумент.Открыть();
    
    Для каждого ТекСтрока из Номенклатура Цикл
    Если ТекСтрока.Заправщик=Истина Тогда
    НовДокумент = Документы.ЛимитноЗаборнаяКарта.СоздатьДокумент();		
    НовДокумент.Заполнить(ссылка);
    НовДокумент.Автор = Автор;
    НовДокумент.Дата = Дата+60;
    НовДокумент.Склад = Заправщик;
    НовДокумент.Отправитель = Заправщик;
    НовДокумент.Организация = Организация;
    НовДокумент.ПоследняяКорректировка = ПоследняяКорректировка;
    НовДокумент.НовыйСклад = ТекСтрока.Транспорт;
    НовДокумент.Получатель = ТекСтрока.Механизатор;
    НовДокумент.Примечание =  "Заполнен по Заявке на топливо № " + Номер + " от " + Дата;
    НоваяСтрока = НовДокумент.Номенклатура.Добавить();
    НоваяСтрока.Номенклатура = ТекСтрока.ВидТоплива;
    НоваяСтрока.Ед = ТекСтрока.Ед;
    НоваяСтрока.Количество = ТекСтрока.Заявлено;
    НоваяСтрока.Коэффициент = 1;
    ФормаНовыйДокумент=НовДокумент.ПолучитьФорму(,ЭтаФорма);
    ФормаНовыйДокумент.открыть();
    Иначе Продолжить;
    КонецЕсли;
    КонецЦикла;	
    КонецПроцедуры
    
    
    Теперь все красиво сворачивает

    Осталось решить последний вопрос, как сделать блокировку документа?
    Нужно чтоб как только записал докумен блокировалось для изменения все кроме колонки Заправлено и Заправщик в табличной части документа.

Поделиться этой страницей