8.х Логотип

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем AndrewP, 7 авг 2008.

  1. TopicStarter Overlay
    AndrewP
    Offline

    AndrewP

    Регистрация:
    10 июн 2008
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Подскажите, плиз, новичку.
    Нужно чтобы печатался логотип компании в накладной "реализация товаров и услуг" и в заказе поставщику.
    Как правильно это сделать? (1С:Предприятие 8.0 (8.0.13.32))
  2. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Вставляешь рисунок в макет. При активном окне макета ---- Главное меню:Таблица-Рисунки-Картинка
    Если же организаций несколько, то придется помучаться: необходимо к каждой организации привязать свой логотип (как это реализовано в справочнике "Номенклатура")
  3. vAn
    Offline

    vAn Опытный в 1С

    Регистрация:
    6 авг 2007
    Сообщения:
    90
    Симпатии:
    0
    Баллы:
    26
    Конфигурация - Документы - Реализация товаров и услуг - Макет
    Конфигурация - Общие - Общие макеты - Торг 12
    и там и там вставлял картинки... нигде они в докементах не появились!? почему?
  4. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Так а в макет вставляет (видишь на макете в конфигураторе?). Посмотри какой макет получаешь перед выводом на печать (Процедура Печать() в модуле документа)
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Мало вставить - надо еще вывести...
  6. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Один из вариантов решения (делалось на конкретной конфе под определенную организацию):
    Код:
    Процедура ПечатьГТ_Kermi() Экспорт
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ГТ",ЭтотОбъект.Ссылка);
    Запрос.Текст = 
    "ВЫБРАТЬ
    |	ГарантийныеТалоныТовары.Номенклатура.НаименованиеПолное КАК Товар,
    |	ГарантийныеТалоныТовары.Количество,
    |	ГарантийныеТалоныТовары.ЕдиницаИзмерения,
    |	ГарантийныеТалоныТовары.НомерСтроки,
    |	ГарантийныеТалоныТовары.Номенклатура.Артикул КАК Артикул
    |ИЗ
    |	Справочник.ГарантийныеТалоны.Товары КАК ГарантийныеТалоныТовары
    |ГДЕ
    |	ГарантийныеТалоныТовары.Ссылка = &ГТ";
    
    ТабДокумент	= Новый ТабличныйДокумент;
    Макет	                             = ПолучитьМакет("ГТ_Kermi");
    
    ОбластьЛоготип = Макет.ПолучитьОбласть("Логотип");
    ТабДокумент.Вывести(ОбластьЛоготип);
    ////
    ОбластьШапка	                     = Макет.ПолучитьОбласть("Шапка");
    ОбластьШапка.Параметры.НомерГТ       = Номер;
    ОбластьШапка.Параметры.ДатаПродажи   = Формат(Дата,"ДЛФ=ДД");
    ОбластьШапка.Параметры.СрокГарантии  = ПериодПрописью(СрокГарантии);
    ТабДокумент.Вывести(ОбластьШапка);
    //////
    
    ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
    
    Результат = Запрос.Выполнить().Выбрать();
    Пока Результат.Следующий() Цикл
    ОбластьНоменклатура.Параметры.Заполнить(Результат);
    ТабДокумент.Вывести(ОбластьНоменклатура);
    КонецЦикла;
    
    ////////
    ОбластьДанныеОПродаже = Макет.ПолучитьОбласть("ДанныеОПродаже");
    
    СведенияОПоставщике = ОписаниеОрганизации(СведенияОЮрФизЛице(Организация, Дата),"ПолноеНаименование,ЮридическийАдрес,ФактическийАдрес,Телефоны,Факс");
    СведенияОПокупателе = ОписаниеОрганизации(СведенияОЮрФизЛице(Контрагент, Дата),"ПолноеНаименование,ЮридическийАдрес,ФактическийАдрес,Телефоны,Факс");
    
    //Если безнал, то печатаем продавца и покупателя
    Если Реализация.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("974") Тогда
    ОбластьДанныеОПродаже.Параметры.ДанныеПродавца   = СведенияОПоставщике;
    ОбластьДанныеОПродаже.Параметры.ДанныеПокупателя = СведенияОПокупателе;
    КонецЕсли;
    
    
    
    ОбластьДанныеОПродаже.Параметры.АдресУстановки   = АдресУстановки;
    
    ТабДокумент.Вывести(ОбластьДанныеОПродаже);
    
    ОбластьГарантийныеОбязательства = Макет.ПолучитьОбласть("ГарантийныеОбязательства");
    ОбластьГарантийныеОбязательства.Параметры.СрокГарантии   = ПериодПрописью(СрокГарантии);
    ТабДокумент.Вывести(ОбластьГарантийныеОбязательства);
    
    ОбластьГарантийныеОбязательства1 = Макет.ПолучитьОбласть("ГарантийныеОбязательства1");
    ТабДокумент.Вывести(ОбластьГарантийныеОбязательства1);
    
    ОбластьГарантийныеРаботы = Макет.ПолучитьОбласть("ГарантийныеРаботы");
    ТабДокумент.Вывести(ОбластьГарантийныеРаботы);
    
    
    ТабДокумент.АвтоМасштаб = Истина;
    ТабДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    НапечататьДокумент(ТабДокумент, , , СформироватьЗаголовокДокументаТриатерм(ЭтотОбъект));
    
    КонецПроцедуры
    
    
    Макет вложен.

    з.ы. Администратору: опять столкнулся с проблемой прикрепления файла (формата .mxl), пришлось архивировать. Предложение: может сделать, чтобы файлы, которые нельзя отобразить прикреплялись как простое вложение?? Спасибо.

    Вложения:

Похожие темы
  1. nany
    Ответов:
    5
    Просмотров:
    1.201
  2. admin
    Ответов:
    3
    Просмотров:
    888
  3. tehnickkm
    Ответов:
    1
    Просмотров:
    551
  4. videomause
    Ответов:
    7
    Просмотров:
    4.001
  5. 1c-ka

    Курилка Логотип 1С

    1c-ka, 18 ноя 2014, в разделе: Курилка
    Ответов:
    18
    Просмотров:
    1.507
Загрузка...

Поделиться этой страницей