8.х Личный Интерфейс

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Letos, 7 янв 2010.

  1. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Вопрос поднимался уже несколько раз, всё почитал и всё равно хрень выходит.
    Есть плановый отдел им нужно буквально 2-3 отчета и один журнал документов, с правами на просмотр.
    Нарисовал им интерфейс с двумя кнопочками. Новую роль навоял. Привязал свой интерфейс, не запускается. Выдаёт "У текущего пользователя нет доступных ролей для запуска информационной базы". Если выдать ему либо "ПолныеПрава" либо "Пользователь" тогда Б.Д. запускается, только прикручивает к моему интерфейсу ещё и стандартные от которых можно перейти на любой другой интерфейс. Разумеется, выдаёт ещё кучу не нужных прав этой роли второй роли.
    P.S. Что делать?
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    В конфигурации зашита проверка установленных ролей В общем модуле "ПолныеПрава" есть функция
    Код:
    Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт
    
    Возврат РольДоступна("ПолныеПрава") ИЛИ РольДоступна("Пользователь") ИЛИ РольДоступна("Администрирование");
    
    КонецФункции
    
    
    Туда через ИЛИ добавляешь те роли, которые должны запускаться отдельно
  3. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Нет в общем модуле такой функции. Перерыл ещё половину модулей где встречается "ПолныеПрава", что-то нет такого в них. Версия 1С 8.1 Предприятие 1.6.19.3.
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Необходимо назначить роль Пользователь
  5. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    Глобальным поиском искали?
  6. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Да искал. Именно такой функции нет.

    Пытаюсь найти что-то по "ПолныеПрава". Правда там многовато, но пока ничего нет.

    Если его назначить у пользователя появляется куча не нужных ему прав, и потом в предприятии "Пользователь" именуетс как "Бухгалтер".

    И пока не забыл, как избавиться от понельки с вкладками, которая появляется при старте, та на которой разбито всё по котигориям?
  7. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Нашёл нужную функцию выгледит немнога иначе

    Код:
    Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт    	
    Если НЕ РольДоступна("ПолныеПрава") И НЕ РольДоступна("Бухгалтер") 
    Тогда  		Отказ = Истина;  				
    Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа");  			
    КонецЕсли; 
    

    Добавил сюда свою роль, но теперь при запуске вылазиет следующая ошибка

  8. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Всё вроди бы и заработало. Пришлось дать ещё кучу прав в "Общие" сделал по аналогии с ролью "Бухгалтерия" и потребовалось в Регистра Сведений дать разрешение на просмотр "СобытияКалендаряБухгалтерия" "НастройкиПравПользователя" и на "НастройкиПользователя" полные права.
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Читайте руководство.
    В каждой типовой есть подобная процедура:
    Код:
    // Процедура проверяет возможность запуска ИБ с определенными для текущего
    // пользователя доступными ролями
    //
    Процедура ПроверитьВозможностьРаботыПользователя(Отказ) Экспорт
    
    Если НЕ ПолныеПрава.ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
    Отказ = Истина;
    #Если Клиент Тогда
    Предупреждение("У текущего пользователя нет доступных ролей, для запуска информационной базы.", 10, "Недостаточно прав доступа");
    #КонецЕсли
    КонецЕсли; 
    
    КонецПроцедуры
    
    
    Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт
    
    Возврат РольДоступна("ПолныеПрава") ИЛИ РольДоступна("Пользователь");
    
    КонецФункции
    
    Роль Пользователь чисто информативная, если не так - значит у Вас не типовая.
  10. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Первая функция точно такая же, только в место "Пользователь стоит" "Бухгалтер" и в синонеме написано: " Бухгалтер (основная рабочая роль) "
    А вот второй функции

    Код:
    Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт
    
    её попросту нет. И 1С типовая. точто с франчи пришло, то и поставили. Без обновления релизов. сейчас (1.6.19.3)
Похожие темы
  1. Zang
    Ответов:
    4
    Просмотров:
    670
Загрузка...

Поделиться этой страницей