7.7 личные карточки 7.7 зик

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем fiskal, 20 янв 2010.

  1. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    Господа умельцы! утро доброе.
    проблемка у меня тут возникла для кого то она элементарная.. но я не как немогу сооброзить как мне это провернуть..
    проблема следущая..
    не типовая конфг...
    личные карточки зик..
    там есть поле ( как и в типовой) совместительства.. туда он выводит данные о совместительстве одном.
    задача следущая если у человека несколько совместительств чтоб он выводил туда даты начала и оканчания всех совместительств..
    пытался по всякому.. но единственное что получаеться что нужно переделывать большую часть модуля

    может быть местные гуру помогут решить проблему элементарней :) добавив пару строк.. выкладываю код..
    Код:
    Если ВС=1 Тогда//внутренние совместительства
    ВнСовм=""; 
    ДопРаб="";
    СпрВС = СоздатьОбъект("Справочник.ДополнительныеРаботы");
    СпрВС.ИспользоватьВладельца(Запрос.Сотрудник);
    СпрВС.ВыбратьЭлементы(1);
    Пока СпрВС.ПолучитьЭлемент()=1 Цикл         
    Если СпрВС.ВидРаботы<>Перечисление.ВидыДопРабот.ВнутрСовм Тогда
    Если (СпрВС.ВидРаботы=Перечисление.ВидыДопРабот.Совмещение)
    или (СпрВС.ВидРаботы=Перечисление.ВидыДопРабот.РасширениеЗоны)
    Тогда
    Дт1 = СпрВС.Начало.Получить(ДатаОтч);
    Дт2 = СпрВС.Окончание.Получить(ДатаОтч);
    Если (ПустоеЗначение(Дт2)=0) И (Дт2>Дт1) И (Дт2<=НачДата) Тогда
    Продолжить;
    КонецЕсли;
    ДопРаб=ДопРаб+СпрВС.ВидРаботы+": "+СпрВС.ПроцентОплаты.Получить(ДатаОтч)+" %;";
    КонецЕсли
    Продолжить;
    КонецЕсли;
    Дт1 = СпрВС.Начало.Получить(ДатаОтч);
    Дт2 = СпрВС.Окончание.Получить(ДатаОтч);
    Если (ПустоеЗначение(Дт2)=0) И (Дт2>Дт1) И (Дт2<=НачДата) Тогда
    Продолжить;
    КонецЕсли;
    ДоплатыВС="";   
    Если ПустоеЗначение(СпрВС.Срок)=0 Тогда
    Дт2=СпрВС.Срок;
    КонецЕсли;
    ВнСовм="с "+Дт1+" по "+Дт2+" ";
    Если ПустоеЗначение(СпрВС.Подразделение)=0 Тогда
    ВнСовм=ВнСовм+"Подр.: "+СпрВС.Подразделение+"; "; 
    КонецЕсли;                                      
    Если ПустоеЗначение(СпрВС.Должность)=0 Тогда
    ВнСовм=ВнСовм+"долж.: "+СпрВС.Должность+"; "; 
    КонецЕсли;
    
    

    Вложения:

  2. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    :) спасибо сразу чтото не получилось оформить
  3. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1

Поделиться этой страницей