7.7 Копирование групп из одного справочника в другой

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Enabea, 1 сен 2008.

  1. TopicStarter Overlay
    Enabea
    Offline

    Enabea

    Регистрация:
    1 сен 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Помогите, пожалуйста.
    В результате кода ниже из справочника ТМЦ в справочник Меню копируются группы самого верхнего уровня, но только те, что содержат подгруппы (простые элементы не учитываются). А как скопировать эти пустые группы, т.е. без подгруп, с или без элементов? И как спозиционироваться внутрь созданных групп? Спасибо.

    Код:
    Процедура ОбработкаПодбора(Эл,Конт)     
    СпрТмц=СоздатьОбъект("Справочник.ТМЦ"); 
    СпрМеню=СоздатьОбъект("Справочник.Меню"); 
    Если Эл.ЭтоГруппа()=1 Тогда     
    Если Вопрос("Добавить группу со всеми элементами?", "Да+Нет")= "Да" Тогда 
    СпрТмц.ИспользоватьРодителя(Эл);                     
    СпрТмц.ВыбратьЭлементы(1); 
    Пока СпрТмц.ПолучитьЭлемент()=1 Цикл              
    Если  СпрТмц.ЭтоГруппа()=0 Тогда 
    СпрМеню.НоваяГруппа();                 
    наим=СпрТмц.Родитель; 
    Пока наим.Уровень()>1 Цикл                         
    наим=наим.Родитель; 
    СпрМеню.Наименование=наим.Наименование;                                             
    КонецЦикла;                     
    СпрМеню.Записать();  
    Возврат;                     
    КонецЕсли;                 
    КонецЦикла;                     
    КонецЕсли; 
    КонецЕсли;         
    КонецПроцедуры
    

Поделиться этой страницей