7.7 Копирование документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем glna, 13 авг 2008.

  1. TopicStarter Overlay
    glna
    Offline

    glna

    Регистрация:
    14 фев 2007
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Можно ли запретить копировать выбранный в журнале документ ?
    Если да, то можно ли это сделать для документов, имеющих конктретное значение реквизита?
    Нужно, чтобы пользователь вообще не мог открыть нового документа, если он нажимает на кнопку "копировать строку".
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    можно... если прописать условие в предопределенной процедуре ПриКопировании...
  3. yXaPb
    Offline

    yXaPb Опытный в 1С

    Регистрация:
    11 дек 2006
    Сообщения:
    77
    Симпатии:
    0
    Баллы:
    26
    Возможно такое решение:

    Код:
    Перем ЗапретКопирования;
    ...........
    //в предопределенной процедуре "ВводНового"
    Процедура ВводНового(Скопирован) 
    Если Скопирован = 1 Тогда     //здесь можно указать и дополнительные условия
    ЗапретКопирования = 1;
    Возврат;        
    КонецЕсли;
    КонецПроцедуры     
    
    //в предопределенной процедуре "ПриОткрытии"
    Процедура ПриОткрытии() 
    Если ЗапретКопирования = 1 Тогда
    Предупреждение("Копирование невозможно !");
    СтатусВозврата(0);           
    КонецЕсли;
    КонецПроцедуры
    
    
    
    ...это на крайний случай :)
  4. TopicStarter Overlay
    glna
    Offline

    glna

    Регистрация:
    14 фев 2007
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Так не получится, т.к. новый документ все равно будет создан.
    Но вопрос снят, нужно в данной процедуре вставить строку СтатусВозврата(0).
  5. yXaPb
    Offline

    yXaPb Опытный в 1С

    Регистрация:
    11 дек 2006
    Сообщения:
    77
    Симпатии:
    0
    Баллы:
    26
    Странно...у меня почему-то не сработал СтатусВозврата(0), поэтому нагородил тут всякого :)

Поделиться этой страницей