8.х ОБМЕН Конвертация из Розницы в УТ

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем `Gshock, 12 дек 2014.

  1. TopicStarter Overlay
    `Gshock
    Offline

    `Gshock

    Регистрация:
    2 дек 2014
    Сообщения:
    8
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста ПКД произвольный алгоритм при за грузке в УТ выдает ошибку
    Ошибка при записи документа
    ИмяПКО = ПеремещениеТоваровНов
    ТипОбъекта = Перемещение товаров
    Объект = Перемещение товаров РТ000000025 от 12.12.2014 8:03:19
    ОписаниеОшибки = Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ОбработкаПроведения': {ОбщийМодуль.Ценообразование.Модуль(352)}: Поле объекта недоступно для записи (ЕдиницаХраненияОстатков)
    ПозицияМодуля = Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(7416)
    КодСообщения = 25

    Это ПКД
    Код:
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Дата", ТекущаяДата());
    Запрос.Текст =   "ВЫБРАТЬ
    |    ПеремещениеТоваровТовары.Ссылка.Номер,
    |    ПеремещениеТоваровТовары.Ссылка.Дата,
    |    ПеремещениеТоваровТовары.Ссылка.Комментарий,
    |    ПеремещениеТоваровТовары.Ссылка.СкладОтправитель,
    |    ПеремещениеТоваровТовары.Ссылка.СкладПолучатель,
    |    ПеремещениеТоваровТовары.Ссылка.Водитель,
    |    ПеремещениеТоваровТовары.Ссылка.ДокументОснование,
    |    ПеремещениеТоваровТовары.Номенклатура,
    |    ПеремещениеТоваровТовары.Количество,
    |    ПеремещениеТоваровТовары.ЕдиницаИзмерения,
    |    ПеремещениеТоваровТовары.Цена,
    |    ПеремещениеТоваровТовары.Сумма,
    |    ПеремещениеТоваровТовары.Коэффициент,
    |    ПеремещениеТоваровТовары.Ссылка
    |ИЗ
    |    Документ.ПеремещениеТоваров.Товары КАК ПеремещениеТоваровТовары
    |ГДЕ
    |    ПеремещениеТоваровТовары.Ссылка.Дата МЕЖДУ НАЧАЛОПЕРИОДА(&Дата, ДЕНЬ) И КОНЕЦПЕРИОДА(&Дата, ДЕНЬ)
    |ИТОГИ ПО
    |    ПеремещениеТоваровТовары.Ссылка";   
       
    
    ВыборкаДок = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока ВыборкаДок.Следующий() Цикл
       
        ИсходящиеДанные = Новый Структура();
        ИсходящиеДанные.Вставить("Дата" , ВыборкаДок.Ссылка.Дата);
        ИсходящиеДанные.Вставить("Номер", ВыборкаДок.Ссылка.Номер);
        ИсходящиеДанные.Вставить("Комментарий", ВыборкаДок.Ссылка.Комментарий);
        Документ = Новый Структура("Дата,Номер",
                                        ВыборкаДок.Ссылка.ДокументОснование.Дата,
                                        ВыборкаДок.Ссылка.ДокументОснование.Номер);
       
                                       
        ИсходящиеДанные.Вставить("ВнутреннийЗаказ" , Документ);
        ИсходящиеДанные.Вставить("Организация"     , "000000001");
        ИсходящиеДанные.Вставить("ОтражатьВУправленческомУчете"    , Истина);
        ИсходящиеДанные.Вставить("Подразделение"   , "УТ0000028");
        ИсходящиеДанные.Вставить("СкладОтправитель", Справочники.Склады.НайтиПоКоду("УТ0000009"));
        ИсходящиеДанные.Вставить("СкладПолучатель", ВыборкаДок.Ссылка.СкладПолучатель);
           
        Выборка = ВыборкаДок.Выбрать();
        ТЗ = Новый ТаблицаЗначений;
        ТЗ.Колонки.Добавить("ЕдиницаИзмерения");
        ТЗ.Колонки.Добавить("Качество");
        ТЗ.Колонки.Добавить("Количество");   
        ТЗ.Колонки.Добавить("Коэффициент");
        ТЗ.Колонки.Добавить("Номенклатура");
        ТЗ.Колонки.Добавить("Цена");
       
        Пока Выборка.Следующий() Цикл
           
            НоваяСтрока = ТЗ.Добавить();
            НоваяСтрока.Качество     = "Новый";
            НоваяСтрока.Количество   = Выборка.Количество;
            НоваяСтрока.Коэффициент  = Выборка.Коэффициент;
            НоваяСтрока.Номенклатура = Выборка.Номенклатура;
            НоваяСтрока.Цена         = Выборка.Цена;
            НоваяСтрока.ЕдиницаИзмерения         = Выборка.ЕдиницаИзмерения;
    
           
        КонецЦикла;   
        ИсходящиеДанные.Вставить("Товары", ТЗ);
    
        ВыгрузитьПоПравилу(,, ИсходящиеДанные, , "ПеремещениеТоваровНов");   
       
    КонецЦикла;
    Это ПКО Единицы Измерения
    Код:
    Если Правила.Номенклатура.Выгруженные[Источник.Владелец] = Неопределено Тогда
        ВыгрузитьПоПравилу(Источник.Владелец);
    КонецЕсли;                 
  2. belka@
    Offline

    belka@

    Регистрация:
    13 дек 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    В работе с данной программой часто сталкиваюсь с разными вопросам. Много ответов искала на разных ресурсах в интернете. Но больше всего полезной информации нахожу в основном вот на этом сайте www.СПАМ

Поделиться этой страницей