8.х Конвертация данных. Переменная не определена (ОбъектНайден)

Тема в разделе "Другие решения", создана пользователем Вурглак, 12 дек 2013.

  1. TopicStarter Overlay
    Вурглак
    Offline

    Вурглак Опытный в 1С

    Регистрация:
    2 янв 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.

    В типовых правилах обмена между УТ 10.3 и Бухгалтерией 2.0 для того чтобы после загрузки документы проводились в числе прочего в обработчике ПослеЗагрузкиОбъекта дописал код

    Код:
    Если ИмяТипаОбъекта = "Документ"
    И Объект.Метаданные().Проведение = Метаданные.СвойстваОбъектов.Проведение.Разрешить Тогда
    Если Не ОбъектНайден  Тогда
    Объект.Записать();
    ОбъектМодифицирован = Ложь;
    КонецЕсли;
    НоваяСтрока =  Параметры.ТаблицаДокументов.Добавить();
    НоваяСтрока.Ссылка = Объект.Ссылка;
    Если Объект.Проведен  Тогда
    НоваяСтрока.Действие = "Проведение";
    ИначеЕсли Объект.ПометкаУдаления  Тогда
    НоваяСтрока.Действие = "Удаление";
    Иначе
    НоваяСтрока.Действие = "Отмена";
    КонецЕсли;
    КонецЕсли;
    Теперь при использовании этих правил почему то выдает ошибку
    ЗАГРУЗКА В ПРИЕМНИКЕ: {Обработка.ОбменДаннымиXML.МодульОбъекта(1596)}: Ошибка в глобальном обработчике события ПослеЗагрузкиОбъекта (конвертация)
    ИмяПКО = КурсыВалют
    ТипОбъекта = Регистр сведений набор записей: Курсы валют
    Объект = РегистрСведенийНаборЗаписей.КурсыВалют
    Обработчик = ПослеЗагрузкиОбъекта (глобальный)
    ОписаниеОшибки = Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(8,13)}: Переменная не определена (ОбъектНайден)
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(6669)
    КодСообщения = 54

    Ошибка при выгрузке данных для узла плана обмена
    ТипОбъекта = Регистр сведений набор записей: Курсы валют
    Объект = РегистрСведенийНаборЗаписей.КурсыВалют
    ОписаниеОшибки = {Обработка.ОбменДаннымиXML.МодульОбъекта(1596)}: Ошибка в глобальном обработчике события ПослеЗагрузкиОбъекта (конвертация)
    ИмяПКО = КурсыВалют
    ТипОбъекта = Регистр сведений набор записей: Курсы валют
    Объект = РегистрСведенийНаборЗаписей.КурсыВалют
    Обработчик = ПослеЗагрузкиОбъекта (глобальный)
    ОписаниеОшибки = Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(8,13)}: Переменная не определена (ОбъектНайден)
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(6669)
    КодСообщения = 54
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1300)
    КодСообщения = 72
    УзелПланаОбмена = Бухгалтерия предприятия, редакция 2.0

    В чем тут может быть дело и как поправить?
  2. TopicStarter Overlay
    Вурглак
    Offline

    Вурглак Опытный в 1С

    Регистрация:
    2 янв 2012
    Сообщения:
    150
    Симпатии:
    0
    Баллы:
    26
    Проблема решилась заменой строки
    Код:
    Если Не ОбъектНайден Тогда
    на
    Код:
    Если Объект.Ссылка.Пустая() Тогда
    но как бы все равно интересно, почему он ругался на ОбъектНайден, если это стандартный параметр обработчика ПослеЗагрузкиОбъекта?

Поделиться этой страницей