7.7 контроль ВводНаОсновании()

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ged, 10 мар 2008.

  1. TopicStarter Overlay
    ged
    Offline

    ged

    Регистрация:
    19 июл 2007
    Сообщения:
    37
    Симпатии:
    0
    Баллы:
    1
    Имеется журнал приходных накладных.
    На их основе можно вводить документ Перемещение.
    Как отловить нажатие ALT+F9 на приходной накладной
    (нужно сделать проверку на подчиненные документы,
    и по результату или одно или другое действие)?
  2. varadat
    Offline

    varadat

    Регистрация:
    25 апр 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    В перемещении вставляешь процедуру ВводНаОсновании(ДокОснование) и в ней проверяешь все что хочешь. При нажатии ALT+F9 выводится список документов которые можно ввести на основании этого документа, при выборе типа документа вызывается процедура ВводНаОсновании в документе который вводится. ALT+F9 отловить нельзя (если ты хочешь что-то проверить до появления списка документов)
  3. MaxxaM
    Offline

    MaxxaM Опытный в 1С

    Регистрация:
    16 окт 2007
    Сообщения:
    288
    Симпатии:
    2
    Баллы:
    29
    Насколько я понимаю цель определить создан ли уже подчиненный документ или нет
    может сей код поможет:

    Код:
    Функция Наклала(ТДок,ТипД) Экспорт
    Док = СоздатьОбъект("Документ");
    Док.ВыбратьПодчиненныеДокументы(,,ТДок);
    если Док.ПолучитьДокумент()=1 тогда
    Если Док.Вид() =ТипД Тогда
    ОткрытьФорму(Док.ТекущийДокумент(),100,1);
    Возврат 1
    КонецЕсли;
    иначе
    Возврат 0;
    Конецесли;  
    КонецФункции 
    
    Процедура ВводНаОсновании(ДокОснование)	
    
    Если Наклала(ДокОснование,"НалоговаяНакладная")=1 Тогда
    Сообщить("Налоговая накладная для данного документа уже создана и мы ее открыли для ВАС!!!");
    Форма.Закрыть(0);
    Возврат; 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	иначе	</span>                 
    ..........
    КонецЕсли;
    КонецПроцедуры
    
    :unsure:
  4. varadat
    Offline

    varadat

    Регистрация:
    25 апр 2007
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    Данный код (см.выше) нужно вставлять в документ Перемещение (а не в накладную)!

Поделиться этой страницей