7.7 Контроль в количестве и цене

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем SerzhM, 20 дек 2011.

  1. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Тис 9,2. Помогите разобраться. Документ ЧекККМ. Получаем строки документа из сканера шк. Если позиция номенклатуры есть, а количество=0 и сумма=0(по этой строчке, из за отсутствия количества, цена есть) и проводишь документ то он его спокойно проводит не говоря что количество пустое.
    Подскажите где сделать и как проверку на пустое количество, цену и сумму. Может где в программе не стоит галочка.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Замените в модуле формы документа одноименную процедуру на эту

    Код:
     
    Процедура ПриЗаписи() 
    Если Модифицированность()=1 Тогда
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если (Количество=0)Или(Сумма=0) Тогда
    Предупреждение("В строке "+НомерСтроки+" не указано количество или сумма",20);
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;			
    КонецЦикла;
    КонецЕсли;
    
    Если глМожноЗаписатьДокумент(Контекст)=0 Тогда
    СтатусВозврата(0);                        
    ИначеЕсли глКонтрольДатыДокумента(Контекст, НачальнаяДатаДокумента)=1 Тогда
    СтатусВозврата(0);
    КонецЕсли;
    
    КонецПроцедуры // ПриЗаписи() 
    
    
  3. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    только я добавил в др процедуру т.к в процедура Записать не срабатывает не доходит почему то до нее при нажатии на кнопку записать или провести поэтому пометил сюда
    Код:
    Процедура ВыполнитьНажатиеНаКнопку(ИмяКнопки)
    
    Если ИмяКнопки="Записать" Тогда
    
    Записать();
    
    ИначеЕсли ИмяКнопки="Провести" Тогда
    
    /////Сергей////////////
    Если Получено=0 Тогда
    Предупреждение("Введите сумму от покуателя!");
    СтатусВозврата(0);
    Возврат;
    КонецЕсли; 
    /////////сергей/////////////////
    //1 Сергей
    Если Модифицированность()=1 Тогда
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если (Количество=0)Или(Сумма=0) Тогда
    Предупреждение("В строке "+НомерСтроки+" не указано количество или сумма",20);
    СтатусВозврата(0);
    Возврат;
    КонецЕсли;			
    КонецЦикла;
    КонецЕсли;
    //2Сергей
    

Поделиться этой страницей