8.х УТ Контроль дебиторской задолженности по договору

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем burbon, 3 июн 2011.

  1. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Всем привет.
    Вот в прошлой теме не так выразился.
    Интересует как контролировать дебиторскую задолженность по договору с клиентом, если я хочу сделать ограничение на сумму задолженности.
  2. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    что, получается в 11 этого параметра нет?

    Вот пример из 10.х, если кто забыл, как там было....

    Вложения:

  3. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    если вы про "контролировать число дней задолженности" то сейчас это реализовано через график оплаты, на соответствующей закладке. вышла книга по УТ 11 в вопросах и ответах, там про это написано))
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Это немного не то, долго на вернисаже с Богачевой это обсуждал...
    Они сейчас думают над этим механизмом (контроль задолженности) но четких сроков пока нет...
    ЗЫ. График не позволит сам заказ до его оплаты провести, а вот надо не дать создавать РТиУ, если есть задолженость в целом по контрагенту.
  5. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Ну вот сделал:

    Вложения:

    • Снимок.JPG
      Снимок.JPG
      Размер файла:
      103,5 КБ
      Просмотров:
      106
  6. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Теперь встал вопрос о том, как контролировать при перепроведении проведенного документа! не подскажите куда воткнуть в модуль объекта РТиУ ??? А то при проведении не проведенного всё нормально, а когда ещё раз провожу, то пишет , что долг есть, хотя этот тот же док. Да и в доке пишет задолженность. какой механизм намутить???
    Ставил точку останова на процедуре удаления проведения, проведение не отменяется. Так как получить актуальную задолженность при перепроведении?

    Вот код:

    Код:
    Процедура КонтрольДебиторскойЗадолженности(Отказ)
    
    Если ЭтотОбъект.Соглашение.КонтролироватьСуммуЗадолженности = Истина Тогда 
    
    СуммаЗадолженности = ПересчетИпроверка.РасчетыСКлиентом(ЭтотОбъект.Партнер, ЭтотОбъект.Дата); 	
    ОстатокПоЗадолженности = ЭтотОбъект.Соглашение.ДопустимаяСуммаЗадолженности - СуммаЗадолженности;
    
    Если ОстатокПоЗадолженности >= ЭтотОбъект.СуммаДокумента Тогда
    Отказ = Ложь;	
    Иначе
    Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Документ не будет проведен, т.к. сумма дебиторской задолженности по соглашению превышена на " + Строка(ОстатокПоЗадолженности) + " руб.";
    Сообщение.Сообщить();
    Отказ = Истина;
    КонецЕсли;
    
    КонецЕсли;
    
    КонецПроцедуры
    

    Вложения:

  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Я бы ставил не в проведение, а сделал бы подписку на событие ПередЗаписью и там бы првоерял (не забудьте проверять режим записи документа)
  8. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    О как, проверю, Спасибо!
    Никогда с подписками ещё не работал. Т.е. создаем свою подписку или уже в существующей?
  9. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Ну сделал через подписку на событие (Содал свое и указал, что ПередЗаписью для РеализацияТУ, там прописал свое условие) и всё равно не могу получить актуальные итоги при перепроведении??? Идет учет этого же документа, что я перепровожу и он пишет, что есть превышение... Куда дальше капнуть???
    Вот как сделал:

    Вложения:

  10. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Это особенность оптимизации - движения не удаляются, а учитываются - нужно ли их менять. Поэтому, Вам нужно или написать свой запрос по получению остатков взаиморасчетов и там вычитать движения текущего документа или вычитать из полученного остатка в модуле.

    Посмотрите, как работает контроль остатков по товару, например, для понимания. Лучше всего сделать именно так, как в типовой - самый оптимизированный вариант для многгопользователського режима.
  11. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Сейчас посмотрим!
  12. TopicStarter Overlay
    burbon
    Offline

    burbon Опытный в 1С

    Регистрация:
    5 май 2009
    Сообщения:
    228
    Симпатии:
    0
    Баллы:
    26
    Не ткнете носом в механизм? Блин вообще не могу понять где это происходит. Сам то я для себя написал, а вот типовой найти не могу!
  13. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    видимо используется новый механизм контроля, когда движения записываются без контроля, а потом выполняется анализ на предмет "минусовых" данных.
    думаю смотреть надо тут

    Код:
    ПроведениеСервер.ВыполнитьКонтрольРезультатовПроведения(ЭтотОбъект, Отказ);
    
    
    в обработке проведения РТиУ

Поделиться этой страницей