7.7 Компонента DialMail: "не работает" метод FTP.Лист()

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем Herby, 29 июл 2014.

  1. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    Проблема при считывании файлов с ftp.

    Подключение к FTP происходит удачно.
    Метод Лист() возвращает 1,

    но далее метод КоличествоФайлов() возвращает 0.

    Хотя, файлы присутствуют в корне каталога 100%.

    Копирование файлов с помощью методов ПолучитьФайл/ПолучитьФайлы - происходит успешно.
    Использование этих методов не спасает, потому что нужно заранее знать точные имена файлов.

    Версия DialMail 2.7.6.16
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Думаю проблема в слеше... у вас наверняка путь задан через "\", а нужно "/"
  3. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    Задаю через "/". В том числе пробую ничего не указывать - т.е. когда считывание происходит с текущего каталога.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    странно. покажите ваш код + версия библы какая?
  5. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если FTP.Подключиться(FTPСервер,    FTPПорт, FTPПользователь,FTPПароль,FTPПассивныйРежим)=0 тогда
           Предупреждение("Не смогли подключиться к   FTP-серверу");
    Иначе
           Подключено = 1;
    КонецЕсли;
      
    Если FTP.Лист() = 1 Тогда
           сообщить(FTP.КоличествоФайлов());
    конецЕсли;
    
    Версия DialMail 2.7.6.16

    В том числе не работает Лист() и в прилагаемой к dll обработке ExampleFTP.ert
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    FTP.Лист(ТутНуженПуть)
  7. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    не помогает, да и путь не обязателен, если путь не указан, то происходит чтение с корня каталога. Да и если бы указал "плохой путь", то Лист() вернул бы "0", а не "1".
    Последнее редактирование: 30 июл 2014
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    не знаю. у меня работает без замечаний. Релиз компоненты какой
  9. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    FTP.ВерсияОбъекта выдает 20707
    при скачке было указано что версия 2.7.6.16
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Да. Версия нормальная. Странно.
    Вот этот код у меня работает без замечаний

    Процедура ПолучитьДанные()
    ФТП.Лист(ВыгрузкаФТП,);
    Для к=1 По ФТП.КоличествоФайлов() Цикл
    ИмяФайла=ФТП.ПолучитьИмяФайла(к);
    Если ФТП.ПолучитьФайл(ВыгрузкаФТП+ИмяФайла,Загрузка1с+ИмяФайла,0)=0 Тогда
    Предупреждение("Ошибка при получении данных. "+РазделительСтрок+
    "Ошибка "+ФТП.ПоследнийОтветСервера+РазделительСтрок+
    "Обмен прерван.");
    ФТП.Отключиться();
    ФТП="";
    Возврат;
    КонецЕсли;
    ФТП.УдалитьФайл(ВыгрузкаФТП+ИмяФайла);
    КонецЦикла;
    КонецПроцедуры
  11. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    у меня этот же код не работает.
    была мысль что на самом фтп какое-то ограничение стоит, но тогда бы я никак не смог просмотреть содержимое.
    но и с проводника захожу - все отображается, и с консоли захожу на фтп и листинг нормально отрабатывает.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Все же что-то у вас не то....
    вот как я подключаюсь

    ФТП = СоздатьОбъект("AddIn.FTP");
    ФТП.ИмяЛогФайла = Путь+"ftp.log";
    ФТП.ВестиЛогФайл = 1;
    ФТП.ВестиТехническийЛогФайл = 1;
    ФТП.NewRFC = 0;
    ФТП.ИспользоватьПрокси = 0;
    ФТП.ИспользоватьSSL = 0;
    ФТП.БинарныйРежим = 1;
    ФТП.ВремяДоРазрыва = 100000;

    Если ФТП.Подключиться(АдресФТП,
    21,
    ЛогинФТП,
    ПарольФТП,1,3)=0 тогда
    Предупреждение("Не смогли подключиться к FTP-серверу");
    НастройкаФТП();
    СтатусВозврата(0);
    Форма.Закрыть();
    Возврат;
    КонецЕсли;
  13. TopicStarter Overlay
    Herby
    Offline

    Herby Опытный в 1С

    Регистрация:
    21 фев 2013
    Сообщения:
    95
    Симпатии:
    0
    Баллы:
    26
    проблема в библиотеке все же.
    поставил версию 2.7.5 - с ней все работает.
    если не затруднит, перешлите вашу версию dialmail на 1c_progr@mail.ru
    Последнее редактирование: 1 авг 2014
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ссылку в личку кинул
  15. Jirogirg
    Offline

    Jirogirg

    Регистрация:
    19 сен 2016
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Ребзи, такая же проблема. Есть у кого 2.7.5? Гугл сломался, не может мне найти. Только 2.7.6 выдаёт. А сам сайт DialMail отдан под продажу коттеджей... Но чтобы мне коттедж купить, нужно задачу закрыть, а для этого нужно, чтобы компонента нормально отработала.
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей