8.х Колонки в ТаблицеЗначений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mitit, 9 июл 2008.

  1. TopicStarter Overlay
    mitit
    Offline

    mitit

    Регистрация:
    9 июл 2008
    Сообщения:
    23
    Симпатии:
    0
    Баллы:
    1
    Всем добрый день!
    У меня такая проблемка.

    Создаю ТаблицуЗначений, у которой неизвестное количествоколонок и Имен колонок, которые берутся из массива.
    Код:
    Для H=1 по КоличествоНадбавок цикл
    МассивКоличестваНадбавок.Добавить(H);
    КонецЦикла;	
    
    Для каждого Имя из МассивКоличестваНадбавок цикл
    ТаблицаНадбавок.Колонки.Добавить(Имя);
    КонецЦикла;	
    
    
    Массив создает нормально, а при создании колонки выдает ошибку :
    Ошибка при вызове метода контекста (Добавить): Неверное имя колонки
    ТаблицаНадбавок.Колонки.Добавить(Имя);
  2. GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Имя колонки должно быть строкой, а в массиве - числа

    Код:
    Для каждого Имя из МассивКоличестваНадбавок цикл
    ТаблицаНадбавок.Колонки.Добавить(Строка(Имя));
    КонецЦикла;    
    
    
    
  3. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Скорее всего такое имя колонки уже есть в таблице!

Поделиться этой страницей