7.7 Количество подзаявок

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 9 сен 2009.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Есть предзаявки.Которые печатаются так:основная и по залам.
    Народ как сделать так чтобы в основной выводилось количество подзаявок(т.е. сколько залов) ,а
    по залам выводился номер по порядку?.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Совершенно непонятный вопрос так как не указана конфигурация
  3. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Торговля и склад.
  4. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Код:
    Процедура ПечатьЗал(пЗал,БПСпособПечати)
    Перем НачПовт, КонПовт;                      
    
    РегХран=СоздатьОбъект("Регистр.ХранениеТовара");
    ТЗН=СоздатьОбъект("ТаблицаЗначений");
    
    ИсхТабл = СоздатьОбъект("Таблица");
    ИсхТабл.ИсходнаяТаблица("ПоЗалам");
    НачПовт = 0; КонПовт = 0;
    ПечФирма = ""; Банк = ""; Счет = ""; БИК = ""; СчетБанка = "";
    
    Параметры = СоздатьОбъект("СписокЗначений");
    //Я написал{    
    Номер="";
    Если Номенклатура.ЗалХранения=СокрЛП("Общий зал") Тогда
    Номер="1";
    КонецЕсли;
    //}Я написал
    
    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
    ИсхТабл.ВывестиСекцию("Шапка");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("Шапка");
    ИсхТабл.ПовторятьПриПечатиСтроки(НачПовт + 1, КонПовт);
    НомСтроки = 0;
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Если Номенклатура.ЗалХранения=пЗал Тогда
    НомСтроки = НомСтроки + 1;
    РегХран.УстановитьФильтр(,Номенклатура);
    РегХран.ВыгрузитьИтоги(ТЗН);
    МХ="";
    ТЗН.ВыбратьСтроки();
    Пока ТЗН.ПолучитьСтроку()=1 Цикл
    МХ=МХ+СокрЛП(ТЗН.Место.Код)+"; ";
    КонецЦикла;        
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЦикла;
    
    ИсхТабл.ВывестиСекцию("Итоги");
    Если БПСпособПечати = 1 Тогда
    СразуНаПринтер = 0;
    Иначе                  
    СразуНаПринтер = 1;
    КонецЕсли;
    Если СразуНаПринтер = 0 Тогда
    ИсхТабл.Опции(0,0,0,0,"ОпцииПечатиПлПор","ПараметрыОкнаПлПор");
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.Защита(1);
    ИсхТабл.ТолькоПросмотр(0);
    ИсхТабл.Показать(глНазваниеДокументаВжурнале(Контекст),"");  
    Иначе     
    ИсхТабл.ПараметрыСтраницы(1,,,,,,,,,1,,"Brother MFC-8820D USB");
    ИсхТабл.Напечатать(0);
    КонецЕсли; 
    
    КонецПроцедуры // ПечатьЗал();
    
    
    Что не так? выдаёт пустое значение .
  5. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    смущает этот кусок
    Код:
    //Я написал{        
    Номер="";    
    Если Номенклатура.ЗалХранения=СокрЛП("Общий зал") Тогда
    Номер="1";
    КонецЕсли;//}Я написал
    
    Что такое номенклатура? элемент таблиячной части? тогда в твоем случае там пустое значение, потому что нужно делать выборку
  6. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Номенклатура справочник. ЗалХранения реквизит(типа справочник ЗалХранения).
    Извиняюсь за глупый вопрос, а как делается выборка?
  7. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
  8. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Делаю так
    Код:
    Номер="";
    ВыбратьСтроки();
    Пока ПолучитьСтроку() =1 Цикл
    Если Номенклатура.ЗалХранения= СокрЛп("общий зал") Тогда
    Номер="1";
    КонецЕсли;
    КонецЦикла;	
    
    
    Один фиг пусто,что я делаю не так?
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    СокрЛП(Номенклатура.ЗалХранения) = СокрЛп("общий зал")
    
    
    Хотя отбор по наименованию - неправильный подход. Лучше "Общий зал" выбирать в форме диалога (ну в крайнем случае отбирать по коду элемента)
  10. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Если это справочник, то сравнивать его наименование нужно. Типа так:
    Код:
    СокрЛП(Номенклатура.ЗалХранения.Наименование) = СокрЛП("общий зал")
    
  11. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Код:
    Номер="";
    ВыбратьСтроки();
    Пока ПолучитьСтроку() =1 Цикл
    Если СокрЛП(Номенклатура.ЗалХранения) = СокрЛП("общий зал") Тогда
    Ном = "1";
    ИначеЕсли СокрЛП(Номенклатура.ЗалХранения) = СокрЛП("Коля клетки") Тогда
    Ном = "2";
    КонецЕсли;
    КонецЦикла;	
    
    
    
    Вот так делаю, и он мне на все залы выдает еденицу.
    Выбирать в форме диалога нельзя т.к. все это делается для удобства пользователя.
    Просто согласно залу нужно чтоб нумеровались подзаявки №1="общий зал"; №2="Коля клетки" и т.д.
    А основная завка по всем позициям выводило число подзаявок.

    Пардон с нумерацией залов разобрался так:
    Код:
    Номер="";
    ВыбратьСтроки();
    Пока ПолучитьСтроку() =1 Цикл
    Если СокрЛП(пЗал) = СокрЛП("общий зал") Тогда
    Ном = "1";
    ИначеЕсли СокрЛП(пЗал) = СокрЛП("Коля клетки") Тогда
    Ном = "2";
    КонецЕсли;
    КонецЦикла;	
    
    
    А вот как сделать так чтобы оснавная заявка выводила число подзаявок незнаю.
  12. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Код:
        Номер="";
    ВыбратьСтроки();
    сч1 = 0;
    сч2 = 0;
    Пока ПолучитьСтроку() =1 Цикл
    Если СокрЛП(пЗал) = "общий зал" Тогда
    сч1 = сч1 + 1;
    Ном = "1";
    ИначеЕсли СокрЛП(пЗал) = "Коля клетки" Тогда
    сч2 = сч2 + 1;
    Ном = "2";
    КонецЕсли;
    КонецЦикла;    
    
    
    P.S. СокрЛП у текста не надо делать там пробелов нет :unsure:
  13. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Вот полная схема процедур печати:

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПечатьЗал[color=red]([/color]пЗал[color=red],[/color]БПСпособПечати[color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачПовт[color=red],[/color] КонПовт[color=red];[/color]                      
    
    РегХран[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Регистр.ХранениеТовара"[/color][color=red])[/color][color=red];[/color]
    ТЗН[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    
    
    ИсхТабл [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"ПоЗалам"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color] КонПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПечФирма [color=red]=[/color] [color=black]""[/color][color=red];[/color] Банк [color=red]=[/color] [color=black]""[/color][color=red];[/color] Счет [color=red]=[/color] [color=black]""[/color][color=red];[/color] БИК [color=red]=[/color] [color=black]""[/color][color=red];[/color] СчетБанка [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    
    Ном[color=red]=[/color][color=black]""[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СокрЛП[color=red]([/color]пЗал[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color][color=black]"общий зал"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Ном [color=red]=[/color] [color=black]"1"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> СокрЛП[color=red]([/color]пЗал[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color][color=black]"Коля клетки"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Ном [color=red]=[/color] [color=black]"2"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> СокрлП[color=red]([/color]пЗал[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color][color=black]"Акмаль корма"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Ном [color=red]=[/color][color=black]"3"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> СокрЛп[color=red]([/color]пЗал[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color][color=black]"Фарход (аквариумы, серко,"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Ном [color=red]=[/color] [color=black]"4"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> СокрлП[color=red]([/color]пЗАл[color=red])[/color] [color=red]=[/color] СокрЛП[color=red]([/color][color=black]"Женя беафар"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Ном [color=red]=[/color] [color=black]"5"[/color][color=red];[/color]        
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]    
    
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    КонПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПовторятьПриПечатиСтроки[color=red]([/color]НачПовт [color=red]+[/color] [color=black]1[/color][color=red],[/color] КонПовт[color=red])[/color][color=red];[/color]
    НомСтроки [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Номенклатура[color=red].[/color]ЗалХранения[color=red]=[/color]пЗал <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НомСтроки [color=red]=[/color] НомСтроки [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    РегХран[color=red].[/color]УстановитьФильтр[color=red]([/color][color=red],[/color]Номенклатура[color=red])[/color][color=red];[/color]
    РегХран[color=red].[/color]ВыгрузитьИтоги[color=red]([/color]ТЗН[color=red])[/color][color=red];[/color]
    МХ[color=red]=[/color][color=black]""[/color][color=red];[/color]
    ТЗН[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ТЗН[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    МХ[color=red]=[/color]МХ[color=red]+[/color]СокрЛП[color=red]([/color]ТЗН[color=red].[/color]Место[color=red].[/color]Код[color=red])[/color][color=red]+[/color][color=black]"; "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]        
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> БПСпособПечати [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СразуНаПринтер [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>                  
    СразуНаПринтер [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СразуНаПринтер [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]"ОпцииПечатиПлПор"[/color][color=red],[/color][color=black]"ПараметрыОкнаПлПор"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=black]"Brother MFC-8820D USB"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Защита[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Показать[color=red]([/color]глНазваниеДокументаВжурнале[color=red]([/color]Контекст[color=red])[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>     
    ИсхТабл[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=black]"Brother MFC-8820D USB"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Напечатать[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПечатьЗал();[/color]
    
    
    
    
    
    
    
    
    
    [color=green]//******************************************************[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> Печать[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачПовт[color=red],[/color] КонПовт[color=red];[/color]                      
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> Р_накл[color=red],[/color] К_Руб_н[color=red],[/color] В_накл[color=red],[/color] К_В_Н[color=red],[/color] БПСпособПечати[color=red];[/color]    
    
    [color=green]//Если (НазваниеИнтерфейса()"Администратор") и (Фирма.Наименование  "Инкос") Тогда[/color]
    [color=green]//    Предупреждение("Нельзя печатать счета не от Инкоса",10);[/color]
    [color=green]//    Возврат;[/color]
    [color=green]//КонецЕсли;[/color]
    
    Параметр    [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]1[/color] [color=red],[/color] [color=black]"Счет"[/color][color=red])[/color][color=red];[/color]
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color]Р_накл [color=red],[/color] [color=black]"Р_накл"[/color][color=red])[/color][color=red];[/color]    
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color]К_Руб_н [color=red],[/color] [color=black]"К_Руб_н"[/color][color=red])[/color][color=red];[/color]    
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color]В_накл [color=red],[/color] [color=black]"В_накл"[/color][color=red])[/color][color=red];[/color]    
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color]К_В_Н [color=red],[/color] [color=black]"К_В_Н"[/color][color=red])[/color][color=red];[/color]    
    Параметр[color=red].[/color]ДобавитьЗначение[color=red]([/color][color=black]2[/color] [color=red],[/color] [color=black]"БПСпособПечати"[/color][color=red])[/color][color=red];[/color]    
    [color=green]// открываем форму обработки[/color]
    ОткрытьФормуМодально[color=red]([/color][color=black]"Обработка.ПакетнаяПечать"[/color][color=red],[/color] Параметр[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"СтатусВозврата"[/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    Р_накл [color=red]=[/color] Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"Р_накл"[/color][color=red])[/color][color=red];[/color]    
    К_Руб_н [color=red]=[/color] Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"К_Руб_н"[/color][color=red])[/color][color=red];[/color]    
    В_накл [color=red]=[/color] Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"В_накл"[/color][color=red])[/color][color=red];[/color]    
    К_В_Н [color=red]=[/color] Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"К_В_Н"[/color][color=red])[/color][color=red];[/color]    
    БПСпособПечати [color=red]=[/color] Параметр[color=red].[/color]Получить[color=red]([/color][color=black]"БПСпособПечати"[/color][color=red])[/color][color=red];[/color]    
    
    ТаблицаДокумента [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    ВыгрузитьТабличнуюЧасть[color=red]([/color]ТаблицаДокумента[color=red])[/color][color=red];[/color]
    СписокПараметровПечати [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]        
    
    
    [color=green]// рублевая заявка[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]Р_накл [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]К_Руб_н [color=red]>[/color] [color=black]0[/color][color=red])[/color]     <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>     
    
    РегХран[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"Регистр.ХранениеТовара"[/color][color=red])[/color][color=red];[/color]
    ТЗН[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    
    ИсхТабл [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"РублеваяЗаявка"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color] КонПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПечФирма [color=red]=[/color] [color=black]""[/color][color=red];[/color] Банк [color=red]=[/color] [color=black]""[/color][color=red];[/color] Счет [color=red]=[/color] [color=black]""[/color][color=red];[/color] БИК [color=red]=[/color] [color=black]""[/color][color=red];[/color] СчетБанка [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]БанковскийСчет[color=red],[/color] [color=black]"БанковскийСчет"[/color][color=red])[/color][color=red];[/color]
    глРеквизитыПлательщикаПолучателя[color=red]([/color]Параметры[color=red])[/color][color=red];[/color]
    ПечФирма     [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"Результат"[/color][color=red])[/color][color=red];[/color]
    Банк        [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"СтрокаБанка"[/color][color=red])[/color][color=red];[/color]
    Счет        [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"РасчетныйСчет"[/color][color=red])[/color][color=red];[/color]
    БИК            [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"БИК"[/color][color=red])[/color][color=red];[/color]
    СчетБанка    [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"КоррСчет"[/color][color=red])[/color][color=red];[/color]
    
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    КонПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПовторятьПриПечатиСтроки[color=red]([/color]НачПовт [color=red]+[/color] [color=black]1[/color][color=red],[/color] КонПовт[color=red])[/color][color=red];[/color]
    НомСтроки [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    ВсегоСумма[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВсегоНДС[color=red]=[/color][color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    НомСтроки [color=red]=[/color] НомСтроки [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Валюта[color=red].[/color]Наименование[color=red]=[/color][color=black]"руб."[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЦенаДок[color=red]=[/color]Окр[color=red]([/color]Цена[color=red]-[/color]Скидка[color=red].[/color]Процент[color=red]/[/color][color=black]100[/color][color=red]*[/color]Цена[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    СуммаДок[color=red]=[/color]Окр[color=red]([/color]ЦенаДок[color=red]*[/color]Количество[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ЦенаДок[color=red]=[/color]Окр[color=red]([/color]Окр[color=red]([/color]Цена[color=red]-[/color]Скидка[color=red].[/color]Процент[color=red]/[/color][color=black]100[/color][color=red]*[/color]Цена[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red]*[/color]КурсДляВалюты[color=red]([/color]Валюта[color=red])[/color][color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color] [color=green]//глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);[/color]
    СуммаДок[color=red]=[/color]Окр[color=red]([/color]ЦенаДок[color=red]*[/color]Количество[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СуммаВклНДС[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    НДСДок[color=red]=[/color]СуммаДок[color=red]*[/color]глВыделяемыйНДС[color=red]([/color]СтавкаНДС[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    НДСДок[color=red]=[/color]СуммаДок[color=red]*[/color]глНачисляемыйНДС[color=red]([/color]СтавкаНДС[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    [color=green]//НДСДок=Окр(СуммаНДС*КурсДляВалюты(Валюта),2,1); //глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);[/color]
    ВсегоНДС[color=red]=[/color]Окр[color=red]([/color]ВсегоНДС[color=red]+[/color]НДСДок[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ВсегоСумма[color=red]=[/color]Окр[color=red]([/color]ВсегоСумма[color=red]+[/color]СуммаДок[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    РегХран[color=red].[/color]УстановитьФильтр[color=red]([/color][color=red],[/color]Номенклатура[color=red])[/color][color=red];[/color]
    РегХран[color=red].[/color]ВыгрузитьИтоги[color=red]([/color]ТЗН[color=red])[/color][color=red];[/color]
    МХ[color=red]=[/color][color=black]""[/color][color=red];[/color]
    ТЗН[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ТЗН[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    МХ[color=red]=[/color]МХ[color=red]+[/color]СокрЛП[color=red]([/color]ТЗН[color=red].[/color]Место[color=red].[/color]Код[color=red])[/color][color=red]+[/color][color=black]"; "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> БПСпособПечати [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СразуНаПринтер [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>                  
    СразуНаПринтер [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СразуНаПринтер [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]"ОпцииПечатиПлПор"[/color][color=red],[/color][color=black]"ПараметрыОкнаПлПор"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=black]"Brother MFC-8820D USB"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Защита[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Показать[color=red]([/color]глНазваниеДокументаВжурнале[color=red]([/color]Контекст[color=red])[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>     
    ИсхТабл[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=black]"Brother MFC-8820D USB"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]КоличествоЭкземпляров[color=red]([/color]К_Руб_н[color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Напечатать[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color] 
    
    БезЗала[color=red]=[/color][color=black]0[/color][color=red];[/color]
    СписокЗалов[color=red]=[/color]СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПустоеЗначение[color=red]([/color]Номенклатура[color=red].[/color]ЗалХранения[color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/сообщить')">Сообщить</span>[color=red]([/color][color=black]"Для "[/color][color=red]+[/color]Номенклатура[color=red].[/color]Наименование[color=red]+[/color][color=black]" не установлена зона отгрузки"[/color][color=red])[/color][color=red];[/color]
    БезЗалов[color=red]=[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СписокЗалов[color=red].[/color]Принадлежит[color=red]([/color]Номенклатура[color=red].[/color]ЗалХранения[color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СписокЗалов[color=red].[/color]ДобавитьЗначение[color=red]([/color]Номенклатура[color=red].[/color]ЗалХранения[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]                                                  
    
    ПечататьЗалы[color=red]=[/color][color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> БезЗалов[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Вопрос[color=red]([/color][color=black]"Для некоторых позиций неуказана зона отгрузки. Печатать без зон?"[/color][color=red],[/color][color=black]"Да+Нет"[/color][color=red])[/color][color=red]<[/color][color=red]>[/color][color=black]"Да"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ПечататьЗалы[color=red]=[/color][color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ПечататьЗалы[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">Для</span> Сч[color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> СписокЗалов[color=red].[/color]РазмерСписка[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    ПечатьЗал[color=red]([/color]СписокЗалов[color=red].[/color]ПолучитьЗначение[color=red]([/color]Сч[color=red])[/color][color=red],[/color]БПСпособПечати[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    
    
    
    
    [color=green]// валютная заявка[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> [color=red]([/color]В_накл [color=red]=[/color] [color=black]1[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]К_В_Н [color=red]>[/color] [color=black]0[/color][color=red])[/color]     <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    ТаблицаДокумента [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"ТаблицаЗначений"[/color][color=red])[/color][color=red];[/color]
    ВыгрузитьТабличнуюЧасть[color=red]([/color]ТаблицаДокумента[color=red],[/color][color=black]"Валюта"[/color][color=red])[/color][color=red];[/color]
    ТаблицаДокумента[color=red].[/color]Свернуть[color=red]([/color][color=black]"Валюта"[/color][color=red],[/color][color=black]"Валюта"[/color][color=red])[/color][color=red];[/color]
    ПечКур[color=red]=[/color][color=black]"Курс: "[/color][color=red];[/color]
    ТаблицаДокумента[color=red].[/color]ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ТаблицаДокумента[color=red].[/color]ПолучитьСтроку[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> ТаблицаДокумента[color=red].[/color]Валюта[color=red].[/color]Наименование[color=red]<[/color][color=red]>[/color][color=black]"руб."[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ПечКур[color=red]=[/color]ПечКур[color=red]+[/color]ТаблицаДокумента[color=red].[/color]Валюта[color=red]+[/color][color=black]" - "[/color][color=red]+[/color]КурсДляВалюты[color=red]([/color]ТаблицаДокумента[color=red].[/color]Валюта[color=red])[/color][color=red]+[/color][color=black]";"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    
    ИсхТабл [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Таблица"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ИсходнаяТаблица[color=red]([/color][color=black]"ПоЗалам"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color] КонПовт [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ПечФирма [color=red]=[/color] [color=black]""[/color][color=red];[/color] Банк [color=red]=[/color] [color=black]""[/color][color=red];[/color] Счет [color=red]=[/color] [color=black]""[/color][color=red];[/color] БИК [color=red]=[/color] [color=black]""[/color][color=red];[/color] СчетБанка [color=red]=[/color] [color=black]""[/color][color=red];[/color]
    [color=green]//пЗал = Номенклатура.ЗалХранения;[/color]
    
    Параметры [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"СписокЗначений"[/color][color=red])[/color][color=red];[/color]
    Параметры[color=red].[/color]ДобавитьЗначение[color=red]([/color]БанковскийСчет[color=red],[/color] [color=black]"БанковскийСчет"[/color][color=red])[/color][color=red];[/color]
    глРеквизитыПлательщикаПолучателя[color=red]([/color]Параметры[color=red])[/color][color=red];[/color]
    ПечФирма     [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"Результат"[/color][color=red])[/color][color=red];[/color]
    Банк        [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"СтрокаБанка"[/color][color=red])[/color][color=red];[/color]
    Счет        [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"РасчетныйСчет"[/color][color=red])[/color][color=red];[/color]
    БИК            [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"БИК"[/color][color=red])[/color][color=red];[/color]
    СчетБанка    [color=red]=[/color] Параметры[color=red].[/color]Получить[color=red]([/color][color=black]"КоррСчет"[/color][color=red])[/color][color=red];[/color]
    
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    НачПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Заголовок"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    КонПовт [color=red]=[/color] НачПовт [color=red]+[/color] ИсхТабл[color=red].[/color]ВысотаСекции[color=red]([/color][color=black]"Шапка"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПовторятьПриПечатиСтроки[color=red]([/color]НачПовт [color=red]+[/color] [color=black]1[/color][color=red],[/color] КонПовт[color=red])[/color][color=red];[/color]
    НомСтроки [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    ВыбратьСтроки[color=red]([/color][color=red])[/color][color=red];[/color]
    ВсегоСумма[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВсегоUSD[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВсегоEUR[color=red]=[/color][color=black]0[/color][color=red];[/color]
    ВсегоRub[color=red]=[/color][color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">Пока</span> ПолучитьСтроку[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    НомСтроки [color=red]=[/color] НомСтроки [color=red]+[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Валюта[color=red].[/color]Наименование[color=red]=[/color][color=black]"руб."[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЦенаДок[color=red]=[/color]Окр[color=red]([/color]Цена[color=red]-[/color]Скидка[color=red].[/color]Процент[color=red]/[/color][color=black]100[/color][color=red]*[/color]Цена[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    СуммаДок[color=red]=[/color]Окр[color=red]([/color]ЦенаДок[color=red]*[/color]Количество[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>
    ЦенаДок[color=red]=[/color]Окр[color=red]([/color]Окр[color=red]([/color]Цена[color=red]-[/color]Скидка[color=red].[/color]Процент[color=red]/[/color][color=black]100[/color][color=red]*[/color]Цена[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red]*[/color]КурсДляВалюты[color=red]([/color]Валюта[color=red])[/color][color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color] [color=green]//глКурсДляВалюты(Договор.ВалютаВзаиморасчетов,ДатаДок),2,1);[/color]
    СуммаДок[color=red]=[/color]Окр[color=red]([/color]ЦенаДок[color=red]*[/color]Количество[color=red],[/color][color=black]3[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"USD"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВсегоUSD[color=red]=[/color]ВсегоUSD[color=red]+[/color]Сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red]=[/color][color=black]"EUR"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВсегоEUR[color=red]=[/color]ВсегоEUR[color=red]+[/color]Сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">ИначеЕсли</span> НРег[color=red]([/color]Лев[color=red]([/color]Валюта[color=red],[/color][color=black]3[/color][color=red])[/color][color=red])[/color][color=red]=[/color][color=black]"руб"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВсегоRub[color=red]=[/color]ВсегоRub[color=red]+[/color]Сумма[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    ВсегоСумма[color=red]=[/color]Окр[color=red]([/color]ВсегоСумма[color=red]+[/color]СуммаДок[color=red],[/color][color=black]2[/color][color=red],[/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Строка"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">КонецЦикла</span>[color=red];[/color]
    ИсхТабл[color=red].[/color]ВывестиСекцию[color=red]([/color][color=black]"Итоги"[/color][color=red])[/color][color=red];[/color]
    [color=green]//            ИсхТабл.ВывестиСекцию("Подписи");[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> БПСпособПечати [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СразуНаПринтер [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">Иначе</span>                  
    СразуНаПринтер [color=red]=[/color] [color=black]1[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> СразуНаПринтер [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ИсхТабл[color=red].[/color]Опции[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]"ОпцииПечатиПлПор"[/color][color=red],[/color][color=black]"ПараметрыОкнаПлПор"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ПараметрыСтраницы[color=red]([/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=red],[/color][color=black]1[/color][color=red],[/color][color=red],[/color][color=black]"Brother MFC-8820D USB"[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Защита[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    ИсхТабл[color=red].[/color]Показать[color=red]([/color]глНазваниеДокументаВжурнале[color=red]([/color]Контекст[color=red])[/color][color=red],[/color][color=black]""[/color][color=red])[/color][color=red];[/color]  
    <span style='cursor: poi
  14. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Не получится так,потому что Общая(осоновная) заявка печатается через Рублевую
    а подзаявки через ПоЗалам(печатьзалы)
    Кстати как можно по другому организовать нумерацию подзаявок,
    так чтобы нумеровалось автоматом,т.е. если добавили новый зал,мне приходилось его в модуль заносит по новой.
    ЗалХранения это реквизит (типа Справочник.ЗалХранения) в справочнике номенклатура.

Поделиться этой страницей