7.7 Количество экземпляров печати

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Peroman, 16 июн 2010.

  1. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Конфигурация ТиС. Вопрос такого рода мне нужно чтобы в заявке печатались бирки столько штук сколько кол-ва товара в данном документе(заявка).

    Код:
     
    // Печать бирок
    Процедура ПечатьБирок()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Бирки");
    ВыбратьСтроки();
    Пока ПолучитьСтроку() > 0 Цикл
    Если ПустоеЗначение(Номенклатура.Комментарий) = 1 Тогда
    Продолжить;
    Иначе
    Если Найти(Номенклатура.Комментарий,"ПО96")>0 Тогда
    ПечТекст=СтрЗаменить(Номенклатура.Комментарий,"ПО96","");
    Таб.ВывестиСекцию("РСТ");
    Иначе
    Таб.ВывестиСекцию("Бирка");
    КонецЕсли;
    
    Таб.ПараметрыСтраницы(1);
    Таб.Показать();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А в чем вопрос-то? И не проще ли все бирки формировать на одном листе? (это что-то вроде ценников как я понял) - уберите метод Показать за цикл
  3. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Вопрос как сделать так чтобы бирок печаталось столько сколько количества товара в документе, и каждая бирка это отдельный лист, 1бирка=1лист(принтер печати термоэтикеток)
    Т.е. получается товар "А" кол-во=20шт. - этикеток "А"-20шт., товар "Б" кол-во=15шт. -этикеток "Б"-15шт. и т.д.
  4. TopicStarter Overlay
    Peroman
    Offline

    Peroman Опытный в 1С

    Регистрация:
    26 май 2009
    Сообщения:
    879
    Симпатии:
    13
    Баллы:
    29
    Всё можно закрыть тему тут всё просто
    Код:
    Для i=1 по Колво Цикл
    ......
    
    Где: "Колво"количество товара

Поделиться этой страницей