7.7 Количественный учет на счете 90.4

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем rossomaha, 25 окт 2009.

  1. TopicStarter Overlay
    rossomaha
    Offline

    rossomaha

    Регистрация:
    25 окт 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Подскажите пожалуйста. Возникла такая проблема.
    Конфигурация ЕСХН. Не ведется количественный учет на счете 90.4.( то есть в плане счетов у счета 90.4 не стоит признак "кол" и как я понял, ставить не желательно.)
    Написал обработку с помощью конструктора:

    Код:
    Процедура Сформировать_Колонки(Ит, Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Ит.ВыбратьПериоды(1);
    Пока Ит.ПолучитьПериод() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|Период");
    КонецЦикла;
    
    КонецПроцедуры
    
    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура,, 1);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "90.4",,,1,,5);
    Таб.ВывестиСекцию("Заголовок");
    Сформировать_Колонки(Ит, Таб, "Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСубконто(ВидыСубконто.Номенклатура);
    Пока Ит.ПолучитьСубконто(ВидыСубконто.Номенклатура) = 1 Цикл
    Сформировать_Колонки(Ит, Таб, "Субконто1");
    КонецЦикла;
    Сформировать_Колонки(Ит, Таб, "Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры
    //}}БУХГАЛТЕРСКИЙ ЗАПРОС  
    
    Процедура ПриОткрытии()
    
    //{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА(Сформировать)
    ВыбНачПериода = НачалоПериодаБИ();
    ВыбКонПериода = КонецПериодаБИ();
    //{{ИНИЦИАЛИЗАЦИЯ БУХГАЛТЕРСКОГО ЗАПРОСА
    
    КонецПроцедуры
    
    
    Но так как количественный учет не ведется, то в таблице отображается номенклатура и сумма, а количество нет.
    Подскажите пожалуйста, что делать дальше.

    [warn=Внимание!]
    При написании кода пользуемся тегами
    [/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если на 90.4 количественный учет не ведется, он 100% должен вестить на каком-то другом. Скорее всего на забалансовом. Посмотрите ВСЕ проводки документа, вызвавшего движения по счету 90.4 и добавьте....
  3. TopicStarter Overlay
    rossomaha
    Offline

    rossomaha

    Регистрация:
    25 окт 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Дело в том, что в проводках документов по 90.4 количество стоит, а в отчете "Оборотно-сальдовая ведомость по счету" отображается только сумма. Мне нужно для бухгалтеров написать обработку внешнюю именно по счету 90.4, чтобы на выходе можно было посмотреть сумму и количество по любому субконто за выбранный период.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Делайте выборку через объект Операции с фильтром по счету 90.4
  5. TopicStarter Overlay
    rossomaha
    Offline

    rossomaha

    Регистрация:
    25 окт 2009
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Это все, что смог. Подскажите пожалуйста, что делать дальше.


    Код:
    //*******************************************
    Процедура Сформировать()     				
    ТЗ = СоздатьОбъект("ТаблицаЗначений"); 
    ТЗ.НоваяКолонка("ДатаОпер"); 
    ТЗ.НоваяКолонка("НомерОпер"); 
    ТЗ.НоваяКолонка("Номенклатура"); 
    ТЗ.НоваяКолонка("Количество"); 
    ТЗ.НоваяКолонка("Сум"); 
    
    Опер = СоздатьОбъект("Операция");  
    Опер.ВыбратьОперацииСПроводками(ДатаНач, ДатаКон,СчетПоКоду("90.4"));
    
    Пока Опер.ПолучитьПроводку() = 1 Цикл 
    ТЗ.НоваяСтрока(); 
    КонецЦикла;
    ТЗ.ВыбратьСтроки();
    ТЗ.Свернуть("1","2");
    
    КонецПроцедуры 
    
    
    
    

Поделиться этой страницей