8.х Код, Наименование непонятно О_о

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем ultroman, 11 июн 2010.

  1. TopicStarter Overlay
    ultroman
    Offline

    ultroman

    Регистрация:
    11 июн 2010
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Создал справочник с иерархией, автоматом в нём создались поля Код, Наименование ну Родитель я их использую, добавил ещё пару полей...

    и вот в чём проблема... после нажатия кнопки выполняется процедура выводящяя число(сумма) из справочника по Коду строки

    Код:
    Процедура Кнопка2Нажатие(Элемент)
    
    Запрос = Новый Запрос;
    
    Запрос.Текст = "ВЫБРАТЬ Справочник.Службы.СуммаДоговора как СумДог
    </span>
    |ИЗ Справочник.Службы
    
    |ГДЕ Код = 555555555";
    
    Результат = Запрос.<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить().Выбрать();
    
    Пока Результат.Следующий() Цикл
    
    ЭлементыФормы.Надпись1.Заголовок = Результат.СумДог;
    
    КонецЦикла; 
    
    КонецПроцедуры   
    
    ни чего не выводит :(
    а код
    Код:
    Процедура Кнопка2Нажатие(Элемент)
    
    Запрос = Новый Запрос;
    
    Запрос.Текст = "ВЫБРАТЬ Код как СумДог
    </span>
    |ИЗ Справочник.Службы
    
    |ГДЕ СуммаДоговора = 10000";
    
    Результат = Запрос.<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить().Выбрать();
    
    Пока Результат.Следующий() Цикл
    
    ЭлементыФормы.Надпись1.Заголовок = Результат.СумДог;
    
    КонецЦикла; 
    
    КонецПроцедуры   
    
    Выводит Код соответствующий строке где находится 10000
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    У вас код 555555555, а не допустим 00555555555?
    Будет думаю так:
    Код:
    ГДЕ Код = ""555555555""
    
    
    А вообще используйте в запросе параметры, т.е. "|ГДЕ Код = &МойКод";", и далее установка параметра запроса.
  3. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Код строковый, а вы указали число. Поэтому для суммы работает, а для кода - нет.
    Вообще правильно использовать параметры запроса.
    а я бы вообще не парился и использовать метод "НайтиПоКоду"
  4. TopicStarter Overlay
    ultroman
    Offline

    ultroman

    Регистрация:
    11 июн 2010
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    благодарю, заработало
    вот с этим тоже буду разбираться
  5. TopicStarter Overlay
    ultroman
    Offline

    ultroman

    Регистрация:
    11 июн 2010
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    блин теперь такая же проблема с полем Родитель

    Код:
    Процедура Кнопка2Нажатие(Элемент)
    
    Запрос = Новый Запрос;
    
    Запрос.Текст = "ВЫБРАТЬ Справочник.Службы.СуммаДоговора как СумДог
    </span>
    |ИЗ Справочник.Службы
    
    |ГДЕ Родитель = &Род";
    
    Запрос.УстановитьПараметр("Род","Разное");
    
    Результат = Запрос.<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить().Выбрать();
    
    Пока Результат.Следующий() Цикл
    
    ЭлементыФормы.Надпись1.Заголовок = Результат.СумДог;
    
    КонецЦикла; 
    
    КонецПроцедуры    
    
    
    
    и опять не чего не выводит:(
  6. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Разный тип значения: родитель - это ссылка на элемент справочника, а вы текстовую строку указываете.
    Код:
    Запрос.УстановитьПараметр("Род", Справочники.Службы.НайтиПоНаименованию("Разное", Истина));
    
    
  7. TopicStarter Overlay
    ultroman
    Offline

    ultroman

    Регистрация:
    11 июн 2010
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    благодарю, разобрался

Поделиться этой страницей