8.х Кнопка подбора на управляемой форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Mikin, 5 авг 2014.

  1. TopicStarter Overlay
    Mikin
    Offline

    Mikin Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Добрый день. Добавил кнопку подбора на управляемую форму. При нажатии открывается форма выбора справочника, но при нажатии на элемент , ничего не происходит. Подскажите ,что делаю не так ?!

    &НаКлиенте
    Процедура Подбор(Команда)

    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("РежимВыбора", Истина);
    ПараметрыФормы.Вставить("ЗакрыватьПриВыборе", Ложь);
    ОткрытьФорму("Справочник.Подразделения.ФормаВыбора", ПараметрыФормы, , ,)

    КонецПроцедуры
  2. Thelearning
    Offline

    Thelearning Профессионал в 1С Команда форума

    Регистрация:
    9 сен 2010
    Сообщения:
    701
    Симпатии:
    72
    Баллы:
    54
    Еще обработку выбора нужно писать.
  3. TopicStarter Overlay
    Mikin
    Offline

    Mikin Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Спасибо. На будущее оставлю, может кому пригодиться.
    Код:
    &НаКлиенте
    Процедура УчастокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
     
       Если ТипЗнч(ВыбранноеЗначение) = Тип("Массив") Тогда
         Для каждого СпрСсылка Из ВыбранноеЗначение Цикл
           ТабУчасток = Отчет.Участоки.Добавить();
           ТабУчасток .Участок= СпрСсылка;
         КонецЦикла;
       Иначе
         ТабУчасток = Отчет.Участоки.Добавить();
         ТабУчасток .Участок= ВЫбранноеЗначение; 
       КонецЕсли;  
    КонецПроцедуры

Поделиться этой страницей