7.7 Книга покупок у ИП 7.7

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем Golemchik, 24 июл 2015.

  1. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    Добрый день. Возникла проблема база 7.700.600 бухгалтерия. Организация - Ип. при формировании в книге покупок для отчета "зачета ндс с аванса" указывается сам Ип, как и должно быть, но вот в поле ИНН\КПП не верно указан ИНН вместо 12 значного числа - первые 10 цифр ИНН, затем \ и последняя цифра. При выгрузке само собой ругается.

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    См. отчет КнигаПокупок1137. Там вообще довольно криворуко реализовано получение ИНН/КПП. Через вид контрагента, а не через поиск разделителя.
    Замени на процедуру
    Код:
    Функция ВернутьИНН_КПП(Стр,Режим)
    
        КПП="";
        Поз=Найти(Стр,"/");
        Если Поз=0 Тогда
            Поз=Найти(Стр,"\");
        КонецЕсли;
        Если Поз<>0 Тогда
            Кпп=Сред(Стр,Поз+1,20);
            Инн=Лев(Стр,Поз-1);
        Иначе
            Инн=Стр;
        КонецЕсли;
       
        Если режим="ИНН" Тогда
            Возврат СокрЛП(ИНН);
        Иначе
            Возврат СокрЛП(КПП);
        КонецЕсли;
    
    КонецФункции
    
    и все д.б. нормально

Поделиться этой страницей