[РЕШЕНО] КД Правильный поиск контрагента

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем dimon_k, 12 мар 2014.

  1. TopicStarter Overlay
    dimon_k
    Offline

    dimon_k Опытный в 1С Команда форума

    Регистрация:
    17 янв 2011
    Сообщения:
    259
    Симпатии:
    17
    Баллы:
    29
    В типовых правилах конвертации из УТ11 в Бух2 для контрагента в полях поиска такой код
    Код:
    Если НомерВариантаПоиска = 1 тогда
        СтрокаИменСвойствПоиска = "ИНН, КПП";
    ИначеЕсли НомерВариантаПоиска = 2 тогда
        СтрокаИменСвойствПоиска = "ИНН";
    Иначе
        СтрокаИменСвойствПоиска = "Наименование";
    КонецЕсли;
    Как его можно изменить чтобы по "Наименование" искал только в случае пустого ИНН?
    А то получается ситуация когда есть контрагент "ВасяПупкин, ИНН 1111111111", завели еще "ВасяПупкин, ИНН 2222222222" и при выгрузке не найдя по ИНН перезаписывает старого "ВасяПупкин" вместо создания нового ...
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Там есть ПараметрыОбъекта, это соответствие. Нужно отладчиком пройтись и посмотреть что передается в него. Там как раз должны быть поля поиска со значениями. По-моему они там хранятся. А уже на основании их делайте условие свое.
  3. Гриша
    Offline

    Гриша Опытный в 1С

    Регистрация:
    4 май 2008
    Сообщения:
    286
    Симпатии:
    5
    Баллы:
    29
    можно вот так
    Код:
    Если СвойстваПоиска["ЭтоГруппа"] = Истина Тогда
        СтрокаИменСвойствПоиска = "Наименование, ЭтоГруппа";
    ИначеЕсли НастройкаПоиска = "Наименование" Тогда
        СтрокаИменСвойствПоиска = "Наименование, ЭтоГруппа";
    ИначеЕсли НастройкаПоиска = "ИННКППНаименование" Тогда
        СтрокаИменСвойствПоиска = "ИНН, КПП, Наименование, ЭтоГруппа";   
    ИначеЕсли НастройкаПоиска = "ИННКПП" Тогда
        СтрокаИменСвойствПоиска = "ИНН, КПП, ЭтоГруппа";   
    Иначе
        СтрокаИменСвойствПоиска = "ИНН, КПП, Наименование, ЭтоГруппа";
    КонецЕсли;
  4. jonsony
    Offline

    jonsony Опытный в 1С Заблокирован

    Регистрация:
    16 апр 2009
    Сообщения:
    224
    Симпатии:
    25
    Баллы:
    29
    вставить проверку на заполненость ИНН
  5. Гриша
    Offline

    Гриша Опытный в 1С

    Регистрация:
    4 май 2008
    Сообщения:
    286
    Симпатии:
    5
    Баллы:
    29
    вот так же
    Код:
    Если СвойстваПоиска["ИНН"] = "" Тогда
    //тогда твой вариант поиска
    КонецЕсли;
    При этом на реквизите ИНН должна стоять галочка поиска
    dimon_k нравится это.
  6. TopicStarter Overlay
    dimon_k
    Offline

    dimon_k Опытный в 1С Команда форума

    Регистрация:
    17 янв 2011
    Сообщения:
    259
    Симпатии:
    17
    Баллы:
    29
    Спасибо! Работает!

Поделиться этой страницей