7.7 категории номенклатуры в 7.7 торговля + склад

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AmoZ, 24 мар 2011.

  1. TopicStarter Overlay
    AmoZ
    Offline

    AmoZ Опытный в 1С

    Регистрация:
    25 дек 2008
    Сообщения:
    123
    Симпатии:
    0
    Баллы:
    26
    День добрый!
    1С 7.7 Торговля + Склад редакция 8.6
    В номенклатуре на закладке "категории" можно добавить категории товаров.
    В конфигураторе в реквизитах не нашел ссылку на справочник категорий.
    Вопрос вообще состоит в том, чтобы вывести номенклатуру и категории этой номенклатуры из документа "расходная накладная" запросом.
    Не подскажете, как можно вывести эти категории?
    Заранее спасибо за ответ.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Это скорее всего подчиненный справочник... Почитайте в справке про атрибут Владелец
  3. TopicStarter Overlay
    AmoZ
    Offline

    AmoZ Опытный в 1С

    Регистрация:
    25 дек 2008
    Сообщения:
    123
    Симпатии:
    0
    Баллы:
    26
    В принципе, разобрался с "Владелец".
    Получилось вывести номенклатуру и категории для каждой:
    Код:
    СпрН = СоздатьОбъект("Справочник.КатегорииТоваров");
    
    Док = СоздатьОбъект("Документ.РасходнаяНакладная");
    Док.ВыбратьДокументы(ВыбНачПериода, ВыбКонПериода);
    
    Пока Док.ПолучитьДокумент()=1 Цикл
    Сообщить(Док.ТекущийДокумент());
    Пока Док.ПолучитьСтроку()=1 Цикл
    Ном = Док.Товар;
    Сообщить(Ном);
    СпрН.ИспользоватьВладельца(Ном); 
    Спрн.ВыбратьЭлементы();
    Пока СпрН.ПолучитьЭлемент()=1 Цикл
    Сообщить(СпрН.Категория);
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;
    
    
    Но необходимо сделать это в запросе, а как догадаться сам не могу.
    Вот мой запрос:
    Код:
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |РасходнаяНакладная = Документ.РасходнаяНакладная.ТекущийДокумент;
    |Номенклатура = Документ.РасходнаяНакладная.Товар;
    |Группировка Номенклатура без групп;
    |"//}}ЗАПРОС
    
    Как в него можно добавить вывод категорий и чтобы потом можно было отбирать документы именно с этой категорией?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В теле запроса - не получится (точнее можно, но это будет изврат и запрос начнет жутко тормозить). При выводе в отчет только. Нужно написать функцию получения категории (смотрите свой первый код) и будет вам счастье

Поделиться этой страницей