8.х Кассовый журнал, выделить цветом.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Letos, 28 дек 2009.

  1. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    не обходимо что бы в журнале "Кассовы документы" приходные ордера в поле суммы "подсвечивались" зелёным а расходные красным. У меня код следующий:

    Код:
        Для каждого ОформлениеСтроки из ОформленияСтрок цикл
    
    Если     
    ЭлементыФормы.ЖурналДокументовСписок.Колонки.ВидДокумента=("Приходный кассовый ордер")
    Тогда
    ОформлениеСтроки.Ячейки.СуммаДокумента.ЦветФона=Новый цвет(255,0,0);
    иначе
    ОформлениеСтроки.Ячейки.СуммаДокумента.ЦветФона=Новый цвет(0,255,0);
    КонецЕсли;
    КонецЦикла; 
    
    
    
    ничего разумеется не работает, проблема в том что он не распознаёт "Приходный кассовый ордер" как быть?
  2. eviloid
    Offline

    eviloid Опытный в 1С

    Регистрация:
    15 май 2008
    Сообщения:
    103
    Симпатии:
    0
    Баллы:
    26
    попробуйте так:
    Код:
    Для Каждого ОформлениеСтроки Из ОформлениеСтрок Цикл
    Если СокрЛП(ОформлениеСтроки.Ячейки["Вид документа"].Текст) = "Приходный кассовый ордер" Тогда
    ОформлениеСтроки.Ячейки.СуммаДокумента.ЦветФона = Новый Цвет(0, 255, 0);
    Иначе
    ОформлениеСтроки.Ячейки.СуммаДокумента.ЦветФона = Новый Цвет(255, 0, 0);
    КонецЕсли;
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    Letos
    Offline

    Letos Опытный в 1С

    Регистрация:
    23 ноя 2009
    Сообщения:
    218
    Симпатии:
    0
    Баллы:
    26
    Спасибо, всё заработало.

Поделиться этой страницей