8.х Кассовая книга

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем AngelKirov, 5 дек 2011.

  1. TopicStarter Overlay
    AngelKirov
    Offline

    AngelKirov

    Регистрация:
    11 ноя 2011
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Помогите пожалуйста. Делаю отчет "Кассовая книга".
    1. при формировании отчета выводятся макеты за каждый день, даже если в этот день не было операций
    2. не выводятся данные о приходном кассовом ордере (данные должны выводится в область "Строка", как правильно прописать путь?)
    3. как сделать чтобы считался приход и расход за день?


    Код:
    Процедура КнопкаСформироватьНажатие(Кнопка)
    ТабДок = Новый ТабличныйДокумент();
    Макет = ЭтотОбъект.ПолучитьМакет("КассоваяКнига");
    
    СледующийДень = КонецДня(ДатаНач);
    Пока СледующийДень <= КонецДня(ДатаКон) Цикл
    
    //тут создаю шапку - дает возможность сделать циклом за каждый день из выбранного периода
    //Вывести область "Заголовок"
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьЗаголовок.Параметры.Заполнить(ЭтотОбъект);
    ОбластьЗаголовок.Параметры.ЗаголовокЛиста = "КАССА за "; 	
    ТабДок.Вывести(ОбластьЗаголовок);
    
    //Вывести область "Шапка"
    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьШапка.Параметры.Заполнить(ЭтотОбъект);
    ТабДок.Вывести(ОбластьШапка);
    
    //Вывести область "Подвал"
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьПодвал.Параметры.Заполнить(ЭтотОбъект);
    //	ОбластьПодвал.Параметры.ПриходЗаДень = 
    //      ОбластьПодвал.Параметры.РасходЗаДень = 
    //	ОбластьПодвал.Параметры.ОстатокНаКонец = 
    ТабДок.Вывести(ОбластьПодвал);
    
    //Вывести область "Подпись"
    ОбластьПодпись = Макет.ПолучитьОбласть("Подпись");
    ОбластьПодпись.Параметры.Заполнить(ЭтотОбъект);
    ОбластьПодпись.Параметры.Кассир = Константы.Кассир.Получить();
    //      ОбластьПодпись.Параметры.КолПриходныхРасходных = 
    ОбластьПодпись.Параметры.Бухгалтер = Константы.ГлБухгалтер.Получить();
    ТабДок.Вывести(ОбластьПодпись);
    
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Истина;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    
    
    //данные по приходу
    ЗапросПКО = Новый Запрос;
    ЗапросПКО.УстановитьПараметр("ДатаНач",ДатаНач);
    ЗапросПКО.УстановитьПараметр("ДатаКон",СледующийДень);
    ЗапросПКО.Текст = "ВЫБРАТЬ
    |   ПриходныйОрдер1.Номер,
    |   ПриходныйОрдер1.Сумма
    |ИЗ
    |   Документ.ПриходныйОрдер1 КАК ПриходныйОрдер1
    |ГДЕ
    |   ПриходныйОрдер1.Дата МЕЖДУ &ДатаНач И &ДатаКон";
    РезультатПКО = ЗапросПКО.Выполнить().Выбрать();
    Пока РезультатПКО.Следующий() Цикл
    //Вывести область "Строка"
    ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
    ОбластьСтрока.Параметры.Заполнить(ЭтотОбъект);
    //	ОбластьСтрока.Параметры.НомерДокумента =  
    ТабДок.Вывести(ОбластьСтрока);
    КонецЦикла;
    
    СледующийДень = КонецДня(СледующийДень + 1*60);      
    КонецЦикла;
    КонецПроцедуры
    
Похожие темы
  1. Ole-ga
    Ответов:
    2
    Просмотров:
    914
  2. Ole-ga
    Ответов:
    0
    Просмотров:
    765
  3. Татьяна37
    Ответов:
    1
    Просмотров:
    429
  4. ofautumn
    Ответов:
    4
    Просмотров:
    472
  5. Peroman
    Ответов:
    10
    Просмотров:
    756
Загрузка...

Поделиться этой страницей