8.х Картинки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dem0lisher, 3 мар 2011.

  1. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.026
    Симпатии:
    51
    Баллы:
    54
    Здравствуйте!
    Прошу прощения за повтор вопроса-объясните подробнее как картинки из одной конфигурации в другую перенести?

    Тот пример по ссылке http://www.1c-pro.ru/index.php?showtopic=30148
    ввел в заблуждение:
    Используя этот код
    Код:
    //Сохранение изображения
    
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    Диалог.Заголовок = "Выберите файл";
    Если Не Диалог.Выбрать() Тогда
    Возврат;
    КонецЕсли;
    
    Данные = Номенклатура.ОсновноеИзображение.Хранилище.Получить();
    Попытка
    Данные.Записать(Диалог.ПолноеИмяФайла);
    Предупреждение("Файл успешно записан!");
    Исключение
    Предупреждение(ОписаниеОшибки());
    КонецПопытки;
    
    //Загрузка изображения в новую базу
    
    МояКартинка = Новый ДвоичныеДанные(ПутьДоФайла);
    ХранилищеКартинки = Новый ХранилищеЗначения(МояКартинка);
    
    // сохранение значения типа ХранилищеЗначения в базе данных
    НовНоменклатура = Справочники.Номенклатура.СоздатьЭлемент();
    НовНоменклатура.Наименование = "Диван ""Маргарита""";
    // реквизит Изображение имеет тип ХранилищеЗначения
    НовНоменклатура.Изображение = ХранилищеКартинки;
    НовНоменклатура.Записать();
    
    
    
    Где сохранятся картинки? Где сохранятся реквизиты выгружаемого справочника?
    Выгрузится вообще что-то?
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Картинки сохраняются здесь:
    Код:
    НовНоменклатура.Изображение = ХранилищеКартинки;
    
  3. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.026
    Симпатии:
    51
    Баллы:
    54
    Сделал все также. В папке "путь" появился файлик без расширения..
    Делаю загрузку все загружает и создает новый элемент справочника.
    Но когда его открываю-ошибка

    Ошибка при установке значения атрибута контекста (Картинка) Несоответствие типов..
    Вот код который выполняется при открытии свежесозданного элемента справочника:

    Код:
    Процедура ПриОткрытии()
    
    Если ЭтоНовый() Тогда
    Возврат;
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе	</span>
    ЭлементыФормы.Карт.Картинка=ФОТО;
    КонецЕсли;
    КонецПроцедуры
    
    
    
    Пробовал в строке ЭлементыФормы.Карт.Картинка=ФОТО; после фото писать "ФОТО.Получить()"
    Тоже ошибка
  4. TopicStarter Overlay
    Dem0lisher
    Offline

    Dem0lisher Профессионал в 1С

    Регистрация:
    4 авг 2009
    Сообщения:
    1.026
    Симпатии:
    51
    Баллы:
    54
    Смотрю отладчиком ФОТ и вижу тип-Двоичные данные, вместо типа занчения "Картинка"

Поделиться этой страницей