7.7 Картинка для номенклатуры и остатков

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем chehonte, 18 мар 2013.

  1. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Добрый день.
    Стоит задача добавить картинку в номенклатуру, а потом выводить ее при печати остатков товара.
    1С 7.7 Бух учет редакция 4.5

    Добавил в форму картинку и кнопку выбрать картинку. В реквизиты ИмяФайлаФото.
    На кнопку Процедура ВставитьФото() , а что писать понятия не имею.

    Может у кого реализовано такое? Скинте код. Спасибо!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    в процедуре печати
    Код:
    
    Функция Рисунок ( Куда,Откуда ) Экспорт
    Куда.Загрузить(Откуда);
    КонецФункции
    
    В макете. Мею-Таблица-Вставить рисунок-картинка
    По объекту ПКМ - свойства - расшифровка

    Рисунок(Таб.ТекущийОбъект,Путь)
    Таб - объект типа таблица
    Путь - строка, содержащая полный путь к файлу картинки
    man37 нравится это.
  3. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    А как выбрать рисунок?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ФС.ВыбратьФайлКартинки
  5. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Спасибо. Картинка загружается, но не сохраняется.
    Сохраняю путь в строку ФайлДляФото. Но

    Процедура ПриОткрытии()
    Если ФайлДляФото <> 0 Тогда
    КартинкаТовара.Загрузить(ФайлДляФото);
    КонецЕсли;
    КонецПроцедуры // ПриОткрытии()

    не работает.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Загрузить куда хотите? Для печатной формы я привел пример
  7. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    ок. Работает. Спасибо!
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
  9. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Подскажите как картинку добавить в таблицу.
    так не работает
    НаимТовара = Товар.Наименование + " " + Товар.ОписаниеТовара;
    Если ФС.СуществуетФайл(Товар.ФайлДляФото) = 1 Тогда //******рисунок
    ФТовара.Загрузить(Товар.ФайлДляФото);
    КонецЕсли;


    ФТовара - ячейка в таблице (выражение)
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    подробная инструкция как вывести картинку на форму - в посте №2 текущей темы.
  11. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    ФТовара = СоздатьОбъект("Картинка");

    НаимТовара = Товар.Наименование + " " + Товар.ОписаниеТовара;
    Если ФС.СуществуетФайл(Товар.ФайлДляФото) = 1 Тогда //******рисунок
    Рисунок(ФТовара,Товар.ФайлДляФото);//ФТовара.Загрузить(Товар.ФайлДляФото);
    КонецЕсли;

    Функция Рисунок ( Куда,Откуда ) Экспорт
    Куда.Загрузить(Откуда);
    КонецФункции

    Не работает. Не выводит картинки.
    Ошибка
    Функция не обнаружена (Рисовать)
    Рисовать<<?>>(Таб.ТекущийОбъект, Путь)
    Функция не обнаружена (Рисовать)
    Рисовать<<?>>(Таб.ТекущийОбъект, Путь)
    Функция не обнаружена (Рисовать)
    Рисовать<<?>>(Таб.ТекущийОбъект, Путь)
    Функция не обнаружена (Рисовать)
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    А где вы взяли "рисовать"????? Вам же 1с и пишет что функция не найдена
  13. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Добавил в расшифровку Рисунок(Таб.ТекущийОбъект,Путь)

    В модуле
    Если ФС.СуществуетФайл(Путь) = 1 Тогда //******рисунок
    Рисунок(Таб.ТекущийОбъект,Путь);
    КонецЕсли;

    Таб.ВывестиСекцию("Группа|НаимТовара");


    Картинок нет.
    Пишет ошибку
    Куда.Загрузить(Откуда);
    {Отчет.ОстаткиТоваровКол.Форма.Модуль(23)}: Общая файловая ошибка при доступе к

    модуль 23 это

    Функция Рисунок ( Куда,Откуда ) Экспорт
    Куда.Загрузить(Откуда); //23
    КонецФункции
  14. TopicStarter Overlay
    chehonte
    Offline

    chehonte Опытный в 1С

    Регистрация:
    26 фев 2007
    Сообщения:
    174
    Симпатии:
    0
    Баллы:
    26
    Спасибо. Тупанул. Думал в модуле надо тоже что-то писать. Все работает!
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей