7.7 Как запретить создавать и редактировать справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Asttoxa, 12 сен 2011.

  1. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    Ребят подскажите как запретить работы первых трех кнопок в Форме списка справочника.

    Делаю так:

    Процедура ПриВводеСтроки()
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры

    Процедура ПриРедактированииНовойСтроки()
    СтатусВозврата(0);
    Возврат;
    КонецПроцедуры

    Все равно создает и кнопки работают :(
  2. leemuar
    Offline

    leemuar Опытный в 1С

    Регистрация:
    21 окт 2010
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    -- удалено: ответ не в ту ветку форума
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Для проверки расставь в этих процедурах точки останова в отладчике, и посмотри, заходит ли в них.

    Думаю, просто в модуле не той формы описаны эти процедуры.
  4. StarLight
    Offline

    StarLight Опытный в 1С

    Регистрация:
    28 июл 2009
    Сообщения:
    212
    Симпатии:
    0
    Баллы:
    26
    А почему ты не повесишь это все на роль?
  5. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    Как не в той ... ставил точки останова не заходит на них.

    Там не от пользователя зависит. А от того с какой формы запускают эту форму списка. Так что права тут не помогут.
  6. StarLight
    Offline

    StarLight Опытный в 1С

    Регистрация:
    28 июл 2009
    Сообщения:
    212
    Симпатии:
    0
    Баллы:
    26
    Потому что действия предопределенные :)
    Жаль, что в 7 нет параметров сеанса, как в 8 :)
  7. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    И точки останова ставил и запускал ту самую форму списка. Но не останавливает. Он даже на них не заходит :(
  8. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну если в них не заходит, значит 100% не в том модуле указал.

    Для справочников есть формы списка (их может быть произвольное количество), модуль элемента, и модуль группы.

    Так вот, если стоит режим редактирования в списке, тогда отрабатывают процедуры соответствующей формы списка. Иначе - модуль формы элемента/группы.
  9. TopicStarter Overlay
    Asttoxa
    Offline

    Asttoxa Опытный в 1С

    Регистрация:
    18 май 2010
    Сообщения:
    525
    Симпатии:
    0
    Баллы:
    26
    Блин ну как не в этом модуле. Чуть выше подымаюсь и на Процедуре ПриОткрытии() он у меня стопорит а чуть ниже на процедуре ПриВводеСтроки() он не стопорит и как я другой модуль запускаю? :angry:
  10. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Вы не дочитали пост WaRDeR:
    Т.е. при редактировании в диалоге указанные обработчики не отрабатываются. Чтобы запретить редактирование элементов, то в модулях форм элемента и группы добавьте код:
    Код:
    Процедура ПриОткрытии()
    СтатусВозврата(0);
    КонецПроцедуры
    
    
    
    P.S. Если нужен только запрет ввода новых элементов, то обработчик ПриОткрытии замените на ВводНового.

    P.P.S. Либо параметр справочника Редактировать установите в значение В списке.

Поделиться этой страницей