7.7 Как Запретить копирование документа по F9

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем balabyt, 23 июн 2008.

  1. TopicStarter Overlay
    balabyt
    Offline

    balabyt

    Регистрация:
    14 авг 2006
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Проблема в следующем. Бухгалтера приспособились копировать документы при создании нового . Что приводит к проблемам в управленческом учете . Что можно сделать чтоб запретить копирование документа ??
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Нууу так вот на вскидку:
    Код:
    Процедура ВводНового()
    Если Скопирован = 1 Тогда
    Предупреждение ("Нельзя копировать");
    СтатусВозврата(0);
    КонецЕсли;
    КонецПроцедуры
    
    
    
  3. TopicStarter Overlay
    balabyt
    Offline

    balabyt

    Регистрация:
    14 авг 2006
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Весь то и вопрос по чем можно интенсифицировать что док скопирован ??

    Скопирован = 1
    Здесь надо поставить индификатор копирования а вот как он описывается ?
  4. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Читаем ЖКК

    Синтаксис:
    ВводНового(<ПризнКопирования>,<ОбъектКопирования>)
    Назначение:
    Предопределенная процедура при интерактивном вводе нового документа.
    Параметры:
    <ПризнКопирования> - признак того, что объект введен копированием. Число: 1 - объект введен копированием, 0 - просто новый объект. Данный признак может быть использован для анализа необходимости инициализации реквизитов нового объекта.
    <ОбъектКопирования> - объект, который был скопирован.
    Замечание:
    Данная процедура может располагаться только в модуле формы документа.
  5. TopicStarter Overlay
    balabyt
    Offline

    balabyt

    Регистрация:
    14 авг 2006
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Спасибо всем . Все нашел .
    Код:
    Процедура ВводНового (Копирование)
    Если Копирование = 1 Тогда
    Предупреждение ("Нельзя копировать",3);
    СтатусВозврата(0);
    КонецЕсли;
    КонецПроцедуры 
    
    
  6. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Ну да, именно это я и имел в виду :)
    Просто не было конфигуратора под рукой.

Поделиться этой страницей