7.7 Как заполнить колонки списка значений реквизитами справочника. 1С ТиС 7.7

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Albert2176, 25 апр 2015.

  1. TopicStarter Overlay
    Albert2176
    Offline

    Albert2176

    Регистрация:
    25 апр 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Имеется Элемент формы Таблица в который предварительно добавлены колонки:

    Таб=СоздатьОбъект("ТаблицаЗначений");
    Таб.НоваяКолонка("Код","Справочник.Номенклатура");
    Таб.НоваяКолонка("Артикул","Справочник.Номенклатура");
    Таб.НоваяКолонка("Номенклатура","Справочник.Номенклатура");
    .....

    Колонка "Номенклатура" заполняется наименованиями товаров из справочника номенклатура следующей процедурой:

    Процедура ЗаполнитьТаблицуТоварами(Таб)
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр=ВыбратьЭлементы();
    КК=20;
    К=2;
    Состояние("Заполнение ...");
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    К=К+1;
    Если К>=КК Тогда
    Состояние("Заполнено " + КК + " ......");
    КК=КК+20;
    КонецЕсли;
    Таб.НоваяСтрока();
    Таб.Номенклатура=Спр.ТекущийЭлемент();
    КонецЦикла;
    КонецПроцедуры

    Нужно также заполнить колонки Код и Артикул значениями и справочника Номенклатура.

    Вывести сообщение с номерами, допустим Артикулов, получается добавлением в процедуру следующего кода

    Эл=Спр.ТекущийЭлемент();
    Артикул=Эл.ПолучитьАтрибут("Артикул");
    Сообщить(Артикул);

    Но вывести артикулы в колонку Артикул таблицу списка значений не получается.
    Тоже самое касается реквизита Код.

    Подскажите, как вывести реквизиты Код и Артикул в соответствующие колонки таблицы списка значений.
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    >как вывести реквизиты Код и Артикул в соответствующие колонки таблицы списка значений.

    всё в кучу
    нет в коде списка значений

    а не присваивается патамучтааа явно задан тип значения - справочник.номенклатура, а присваивается число
    разницу видишь?
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Проще говоря типизацию колонок ТаблицаЗначений уберите...
    Да и через запрос было бы проще и быстрее заполнить.
  4. TopicStarter Overlay
    Albert2176
    Offline

    Albert2176

    Регистрация:
    25 апр 2015
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1

    Спасибо! Все получилось. С остальными полями тоже разобрался.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей