8.х как закрыть доступность к ячейке строки?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Тимон, 12 янв 2011.

  1. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    В ТЧ документа имеются колонки Приход,Расход,Отдел,Статья Доходов и Статья Расходов.При изменении прихода Расход обнуляется,СтатьяРасходов недоступна,при изменении Расхода соответственно наоборот...у меня получается сделать недоступной не ячейку строки,которую мы вводим,а вообще всю колонку через:

    Процедура ТЧПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущиеДанные;
    Если СтрокаТЧ.Приход>0 Тогда
    ЭлементыФормы.ТЧ.Колонки.Расход.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Ложь;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Истина;
    ИначеЕсли СтрокаТЧ.Расход>0 Тогда
    ЭлементыФормы.ТЧ.Колонки.Приход.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Ложь;
    КонецЕсли;
    КонецПроцедуры


    Процедура ТЧПриходПриИзменении(Элемент)
    //СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущиеДанные;
    СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущаяСтрока;
    Если СтрокаТЧ.Приход>0 Тогда
    ЭлементыФормы.ТЧ.ИзменитьСтроку();
    СтрокаТЧ.Расход=0;
    СтрокаТЧ.СтатьяРасходов=0;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Ложь;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Истина;
    КонецЕсли;
    КонецПроцедуры

    Как мне прописать недопустимость ввода значения лишь в ячейку заполняемой строки?

    Вложения:

Поделиться этой страницей