8.х Как задать формулу в документе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем GSA1112, 14 май 2017.

  1. TopicStarter Overlay
    GSA1112
    Offline

    GSA1112

    Регистрация:
    5 май 2017
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Всем Здравствуйте!
    Я студент и выполняю разработку модуля в 1с: УПП в рамках курсовой работы.
    Нужна помощь.
    Создал документ, представленный на рисунке.
    Не представляю как посчитать сумму по строчкам кварталов.
    Например:
    Необходимо, чтобы по строчке "Квартал1" и по столбцу "Хоз. нужды Вода" автоматом посчиталась сумма 13.
    по строчке "Квартал2" и по столбцу "Хоз. нужды Вода" автоматом посчиталась сумма 8 и т. д.
    Я конкретный чайник, который хочет и готов учиться.
    Пожалуйста, напишите подробно как этого добиться.
    Я думаю, тут нужен код, который будет ссылаться на ячейки. Так ли это?

    Вложения:

    • 111.png
      111.png
      Размер файла:
      29,8 КБ
      Просмотров:
      8
  2. TrasserZero
    Offline

    TrasserZero Опытный в 1С

    Регистрация:
    26 окт 2016
    Сообщения:
    57
    Симпатии:
    2
    Баллы:
    29
    Это основы основ языка.. Привяжитесь к событию ПриИзменении и суммируйте на здоровье.. Гугль Вам поможет в решении, описывать здесь это трудно - многабукафф..
  3. TopicStarter Overlay
    GSA1112
    Offline

    GSA1112

    Регистрация:
    5 май 2017
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    К сожалению гугл не помогает.
    Научился использовать данное событие для подсчета суммы в строчке.
    Для этого присваиваю определенному столбцу событие и пишу код.
    А тут надо присвоить событие не колонке, а строчке.

    Не понимаю как это сделать(( Поделитесь кусочком кода. Очень прошу помощи!!!
  4. TrasserZero
    Offline

    TrasserZero Опытный в 1С

    Регистрация:
    26 окт 2016
    Сообщения:
    57
    Симпатии:
    2
    Баллы:
    29
    Первая найденная строка в поисковике:

    8.2: Пересчет Суммы при изменении Цены или Количества
    Автоматическое вычисление суммы по введенным цене и количеству
    реализуется в обработчиках реквизитов формы "ПриИзменении".


    Создаем обработчики события "ПриИзменении" для реквизитов табличной части "Цена" и "Количество". Для этого в свойствах реквизитов формы (список свойств прокручиваем вниз) щелкаем на "лупу" для события ПриИзменении.

    В модуле формы создаются пустые процедуры, в которых пишем:
    Код:
    &НаКлиенте
    Процедура ТоварыЦенаПриИзменении(Элемент)
    СтрокаТЧ = Элементы.Товары.ТекущиеДанные;
    СтрокаТЧ.Сумма = СтрокаТЧ.Цена * СтрокаТЧ.Количество;
    КонецПроцедуры
    
    &НаКлиенте
    Процедура ТоварыКоличествоПриИзменении(Элемент)
    СтрокаТЧ = Элементы.Товары.ТекущиеДанные;
    СтрокаТЧ.Сумма = СтрокаТЧ.Цена * СтрокаТЧ.Количество;
    КонецПроцедуры
  5. TopicStarter Overlay
    GSA1112
    Offline

    GSA1112

    Регистрация:
    5 май 2017
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1

    В том то и дело, что такую штуку дела не раз.
    В данном случае используется строка табличной части. Т.е. В строке у нас есть цена товара и кол-во. Умножаем и получаем Сумму. Это могу.
    Мне же надо сделать что-то подобное, но не для строки, а для колонки.
    Событие "При изменении" должно относится к периоду.
    Т.е. по столбцу нужно сделать так, чтобы 1квартал-Январь+Февраль+Март

    Пытаюсь преобразовать код в что-то подобное, но не могу довести до ума.

    Процедура ЭнергоресурсыЯнварьПриИзменении(Элемент)
    СтрокаТЧ = Элементы.Энергоресурсы.ТекущиеДанные;
    СтрокаТЧ.1Квартал = СтрокаТЧ.Январь+СтрокаТЧ.Февраль+СтрокаТЧ.Март;
    КонецПроцедуры
  6. TrasserZero
    Offline

    TrasserZero Опытный в 1С

    Регистрация:
    26 окт 2016
    Сообщения:
    57
    Симпатии:
    2
    Баллы:
    29
    Тогда итог вам в помощь

    на табличной части - галка отображать подвал
    на колонке Сумма - отображать итоги в подвале.
  7. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    7.907
    Симпатии:
    506
    Баллы:
    204
    Забавно у Вас заполняется табл часть. А можете конфу скинуть?

Поделиться этой страницей