8.х Как вывести значения ячеек тз согласно условиям в соответствующие ячейки в макете

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем katod, 6 апр 2017.

  1. TopicStarter Overlay
    katod
    Offline

    katod

    Регистрация:
    30 мар 2017
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Как вывести значения ячеек тз, получаемой из запроса, согласно условиям в соответствующие ячейки в макете?
    колонки тз (получаемую из запроса):
    Категория штат факт подразделение

    Код:
      Для каждого строка из тз цикл
           Если строка.категория = Специалисты тогда
                 Обл.Параметры.фактС    = строка.Факт;
                 Обл.Параметры.постС    = строка.Пост;
            ИначеЕсли строка.категория = ВспРаб тогда
                 Обл.Параметры.фактРа   = строка.Факт;
                 Обл.Параметры.постРа   = строка.Пост;
            ИначеЕсли строка.категория = Руководители тогда
                 Обл.Параметры.фактР    = строка.Факт;
                 Обл.Параметры.постР    = строка.Пост;
            КонецЕсли;
            ТабДок.Вывести(Обл);
           КонецЦикла;
    
    выводит не правильно.
    В чем разница между секцией и областью?
    Между методами присоединить и вывести?

    Код:
    СекцияП = ТабличныйДокумент.ПолучитьОбласть("R2C1");
    
    Для каждого строка из тз Цикл
    
                СекцияП.Параметры.Подразделение = строка.ПодразделениеПолное;
                ТабличныйДокумент.Вывести(СекцияП);
            КонецЦикла;
    пишет: Поле объекта не обнаружено (Подразделение)
    Последнее редактирование: 6 апр 2017
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.128
    Симпатии:
    953
    Баллы:
    204
    У табличного документа нет параметров от слова совсем, параметры есть у макета.
    Если секцией вы называете некую область табличного документа, то различий между областью нет.

Поделиться этой страницей