7.7 Как вывести данные проводки в печатную форму?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем daab, 3 фев 2012.

  1. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    И еще раз доброго

    Бухгалтерия 4.5

    Как вывести данные проводки в печатную форму?

    Надо вывести данные табличной части документа "Услуги сторонних организаций" в отчет Акт об оказании услуг
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Конкретную конфигурацию не знаю, но вроде бы во всех типовых настройках в журналах есть кнопка "Действие", по которой можно вывести движения документа и бух.проводки.
  3. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    судя по вопросу в голове полная каша
    я так понимаю, надо напечатать акт от поставщика услуг из документа услуги сторонних организаций, а там и печать-то не предусмотрена

    вариантов 2
    1.написать внешний отчет самому по аналогии с актом из дока оказание услуг
    2.нанять спеца, он и напишет

    выбирай

    зы: по п.1 могу в 2-х словах объяснить последовательность действий
  4. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Объясни в двух словах пожалуйста.

    Фишка в том, что Док "оказание услуг" и док "услуги сторонних организаций" в конфе по разному формируются
  5. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    я так и не услышал подроюное объянение тог что необходимо
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В типовой печать из документа услуг сторонних организаций вообще не предусмотрена.
  7. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Вывести в табличную часть формы "Акт об оказании услуг" данные(наименование, сумма) из документа Услуги сторонних организаций
  8. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    на печать вывести из документа услуги стор.организаций (т.е. типа от поставщика сделать акт оказания услуг)?
    т.е. о чем я сказал в (3)?
  9. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    пример как вставить кнопку печати в док поступлениетоваров, делай по аналогии
    как сделать внешнюю форму акта расскажу позже.
    1.Открываем форму дока, где есть кнопа Печать, например, ПоступлениеМатериалов.
    2.Копируем кнопку Печать и слева от неё кнопу выбора печформы и вставляем в форму ПоступлениеТоваров.
    3.Открываем модуль формы ПоступлениеМатериалов, вверху модкля копируем
    Код:
    Перем ТаблицаПечФорм;  // список печатных форм документа
    Перем НомерТекущейФормы;
    
    аналогично вставляем в начало модуля формы ПоступлениеТоваров
    4.Идем вниз модуля формы ПоступлениеМатериалов, копируем
    Код:
    ТаблицаПечФорм  = СоздатьОбъект("ТаблицаЗначений");
    ТаблицаПечФорм.НоваяКолонка("Название","Строка",,,,30);
    ТаблицаПечФорм.НоваяКолонка("Файл","Строка",,,"Файл",10);
    ТаблицаПечФорм.НоваяКолонка("Кнопка","Строка",,,,10);
    ТаблицаПечФорм.НоваяКолонка("ФайлОписания","Строка");
    
    вставляем в самый конец модуля формы ПоступлениеТоваров после строк
    Код:
    СписокВариантовОтраженияВозврата.ДобавитьЗначение(1, "в книге покупок");
    СписокВариантовОтраженияВозврата.ДобавитьЗначение(0, "в книге продаж");
    
    5.Ищем в модуле формы ПоступлениеМатериалов 2 процедуры
    Код:
    //******************************************************************************
    // ПоКнопкеПечать()
    //
    // Вызывается из формул элементов диалога:
    //  Кнопка "кнПечать".
    //
    // Описание:
    //  Определяется соответствующая печатная форма.
    // 
    Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
    Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
    НомерТекущейФормы = 1;
    Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
    КонецЕсли;
    Если НомерТекущейФормы = 1  Тогда
    Печать();
    
    Иначе
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(Контекст, "Контекст");
    Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
    Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
    
    ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
    КонецЕсли;
    КонецПроцедуры // ПоКнопкеПечать()
    //******************************************************************************
    // ПоКнопкеВыборПечатнойФормы()
    //
    // Вызывается из формул элементов диалога:
    //  Кнопка "кнВыбПечать".
    //
    // Описание:
    //  - открывает список для выбора способа печати.
    //  - формирует таблицу по выбранному способу.
    //
    Процедура ПоКнопкеВыборПечатнойФормы()
    ВыбНомер = глВыборПечатнойФормы("Документ." + Вид(), ТаблицаПечФорм);
    Если ВыбНомер > 0 Тогда
    НомерТекущейФормы = ВыбНомер;
    Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
    ПоКнопкеПечать();
    КонецЕсли;
    КонецПроцедуры // ПоКнопкеВыборПечатнойФормы()
    копируем и вставляем в конце модуля ПоступлениеТоваров перед строкой
    //******************************************************************************
    Новый = 0;
    Во вставленном тексте процедуру ПоКнопкеПечать заменить на этот текст, либо заккоментировать строки (т.е. поставить // в начале стоки) как показано ниже
    //******************************************************************************
    // ПоКнопкеПечать()
    //
    // Вызывается из формул элементов диалога:
    //  Кнопка "кнПечать".
    //
    // Описание:
    //  Определяется соответствующая печатная форма.
    // 
    Процедура ПоКнопкеПечать(СразуНаПринтер = 0,КолЭкз = 1)
    кСтрок=ТаблицаПечФорм.КоличествоСтрок();
    Если кСтрок>0 Тогда
    Если  ПустоеЗначение(НомерТекущейФормы) = 1  Тогда
    НомерТекущейФормы = 1;
    Форма.кнПечать.Заголовок(ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы, "Кнопка"));
    КонецЕсли;
    
    //  Если НомерТекущейФормы = 1  Тогда
    //Печать();
    
    //  Иначе
    Параметры = СоздатьОбъект("СписокЗначений");
    Параметры.ДобавитьЗначение(Контекст, "Контекст");
    Параметры.ДобавитьЗначение(СразуНаПринтер, "Устройство");
    Параметры.ДобавитьЗначение(КолЭкз, "КоличествоКопий");
    
    ОткрытьФорму("Отчет", Параметры, глКаталогПечФорм+ТаблицаПечФорм.ПолучитьЗначение(НомерТекущейФормы,"Файл"));
    //  КонецЕсли;
    КонецЕсли;
    КонецПроцедуры // ПоКнопкеПечать()
    6. Ищем в модуле формы ПоступлениеМатериалов конец процедуры поиском по "// ПриОткрытии", строки
    Код:
    // Заполним таблицу для выбора печатной формы
    НомерТекущейФормы = глУстановкаКнопкиПечать(Контекст, "Документ." + Вид(),ТаблицаПечФорм);
    
    копируем и вставляем по аналогии в конец процедуры ПриОткрытии формы ПоступлениеТоваров

    Собссно всё. Сохраняем, пользуемся, наслаждаемя.
    Не забываем, что вы внесли изменения в конфигурацию при обновлении.
    Но даже если забыли, это не критично, на данные не влияет, повторяем вышеописанные действия и всё.
    В общем, при определенной сноровке, делов на 5 мин.
  10. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Давайте уважать друг друга и пользоваться тегами?!
  11. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Хряк благодарю тебя

    Только ето все понятно, и в поступлении сделано

    А вот как вывести данные из документа "услуги сторонних организаций" в печатную форму :icon_avatar-174:
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Из самого документа?
    Используйте объект Операция. В ней НайтиОперацию ну и ВыбратьПроводки.....
  13. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    да пришлось вшивать форму таблицы в документ, а хотел изначально чтоб из внешний формы печаталось

    Всем большое спасибо, проблема решена
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Зачем? Передаете же контекст....
  15. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    да ладно уже, тут ТиС начали юзать дорабатывать много надо
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
Похожие темы
  1. ATOLL
    Ответов:
    3
    Просмотров:
    1.177
  2. lumor
    Ответов:
    3
    Просмотров:
    1.978
  3. 4ndr3j
    Ответов:
    3
    Просмотров:
    709
  4. Irbison
    Ответов:
    17
    Просмотров:
    2.506
  5. ExtreMe
    Ответов:
    16
    Просмотров:
    6.595
Загрузка...

Поделиться этой страницей