8.х Как выгнать всех пользователей из 1С?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем saleks2001, 18 дек 2007.

  1. TopicStarter Overlay
    saleks2001
    Offline

    saleks2001

    Регистрация:
    27 сен 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Подскажите, кто знает, готовую процедуру или обработку, чтоб перед выгрузкой dt -шника - автоматически выгоняла всех пользователей из БД.
  2. mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    А чем не устраивает делать это вручную. В сервере 1С предприятия можно вручную обрубать соединения
  3. fedor40
    Offline

    fedor40 Опытный в 1С

    Регистрация:
    15 дек 2007
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    В УТ есть обратока Сервис - Пользователи - Блоировка соединения с иф базой.
  4. TopicStarter Overlay
    saleks2001
    Offline

    saleks2001

    Регистрация:
    27 сен 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Дело в том, что делать это нужно ночью при выполнении ночного бекапа и процесс должен выполняться автоматически.
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Сделай нечто типа:

    Код:
    Процедура ПриНачалеРаботыСистемы()
    ...
    ПодключитьОбработчикОжидания("КонтрольРежимаЗавершенияРаботыПользователей", 300);
    ...
    КонецПроцедуры
    
    Процедура КонтрольРежимаЗавершенияРаботыПользователей()
    Если ПораЗакрыватся Тогда
    ЗавершитьРаботуСистемы();
    КонецЕсли
    КонецПроцедуры
    
  6. TopicStarter Overlay
    saleks2001
    Offline

    saleks2001

    Регистрация:
    27 сен 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    В процедуре: "ПриНачалеРаботыСистемы" не работает
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Что не работает?
  8. TopicStarter Overlay
    saleks2001
    Offline

    saleks2001

    Регистрация:
    27 сен 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Не работат обработчик ожидания, выдаёт ошибку, что недопустимое значение 1 параметра, если как-то иначе обозвать процедуру, ошибок нет, но и реакции никакой.
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Конфа какая?
    Скорее всего - такая процедура уже есть :)
  10. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Я так понял проблема в том, что кроме завершения работы бывает, чт осеансы зависают на сервере? Правильно? Или надо просто повыкидывать всех - тогда во всех новых конфах есть такая штука в Сервисе.
  11. TopicStarter Overlay
    saleks2001
    Offline

    saleks2001

    Регистрация:
    27 сен 2007
    Сообщения:
    22
    Симпатии:
    0
    Баллы:
    1
    Всё, разобрался, работает, если сделать так:


    Процедура ЗавершениеРаботыПользователей()Экспорт

    Если (Час(ТекущаяДата()))=22 Тогда
    ПрекратитьРаботуСистемы();
    КонецЕсли;

    КонецПроцедуры


    Процедура ПриНачалеРаботыСистемы()

    ПодключитьОбработчикОжидания("ЗавершениеРаботыПользователей",60);

    КонецПроцедуры


    Всем спасибо!

Поделиться этой страницей