7.7 Как выбрать данние за период по дням.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем DimkaAV, 27 июл 2011.

  1. TopicStarter Overlay
    DimkaAV
    Offline

    DimkaAV

    Регистрация:
    24 июн 2010
    Сообщения:
    43
    Симпатии:
    0
    Баллы:
    1
    Есть код

    Код:
    	
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ИспользоватьСубконто(ВидыСубконто.МестаХранения, ВыбСубконто1, 1);
    Ит.ИспользоватьСубконто(ВидыСубконто.Номенклатура, ВыбСубконто2, 1);
    Ит.ВыполнитьЗапрос(НачПерид, КонПерид, "43.1",,, 1,"День", "К");        
    
    Ит.ВыбратьПериоды();
    Пока Ит.ПолучитьПериод() = 1 Цикл
    
    МХ 			 = Ит.Субконто(ВидыСубконто.МестаХранения).Подразделение;
    Номенклатура = Ит.Субконто(ВидыСубконто.Номенклатура);
    
    Если ТабМестХранения.НайтиЗначение(МХ, 0, "МестоХранения") = 0 Тогда
    ТабМестХранения.НоваяСтрока();
    ТабМестХранения.МестоХранения = МХ;
    КонецЕсли;
    
    Если ТабКормов.НайтиЗначение(Номенклатура, 0, "Номенклатура") = 0 Тогда
    ТабКормов.НоваяСтрока();
    ТабКормов.Номенклатура = Номенклатура;
    КонецЕсли;
    
    ИтТаб.НоваяСтрока();
    ИтТаб.МестоХранения = МХ;
    ИтТаб.Номенклатура  = Номенклатура;
    ИтТаб.Дата 			= ИТ.НачДата;
    ИтТаб.КолВоПриход	= ИТ.ДО(); //ИТ.Операция.Количество;
    
    КонецЦикла;
    
    
    Несмотря на то, что я указываю в "ВыполнитьЗапрос" что хочу только "К" (количество) я получаю сумму, если пишу ИТ.ДО("К") то получаю ноль...
    Пишу "СК" - эффет тот же, суммы есть а кол-во нету.

    Как быть или что я не так делаю, чтобы получить количество?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ну как вариант, по какому-либо из субконто может не вестись количественный учет.

    А вообще желательно еще указать конфу и платформу.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    + ни в одной типовой конфе не видел субсчетов у счета готовой продукции... Рукоблудством попахивает

Поделиться этой страницей