7.7 Как вставить текст из файла в таблицу mxl

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем krasdok, 27 ноя 2012.

  1. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!
    Возможно ли из текстового файла вставить текст в таблицу (в ячейку или объект типа текст)???
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Можно. Ограничение 255 символов
  3. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Примерчик можно...плиззз!
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Область(<Адрес>)
    Назначение:
    Возвращает значение типа ''ОбластьТаблицы'' области секции таблицы или секции таблицы в режиме ввода данных.
    Параметры:
    <Адрес> - необязательный параметр. Строковое выражение, задающее имя области или адрес в формате ''R1C1:R2C2''. Если метод вызван без параметров, то область задана всей секцией.



    Текст
    Назначение:
    Атрибут позволяет прочитать/установить значение текста области (аналогично тому, как в конфигураторе интерактивно задают значение формулы в свойствах ячейки таблицы ''Свойства''- закладка ''Текст'').
  5. GlukAl
    Offline

    GlukAl Опытный в 1С

    Регистрация:
    4 окт 2012
    Сообщения:
    187
    Симпатии:
    7
    Баллы:
    29
    Код:
    текстФайл=СоздатьОбьект("Текст");
    текстФайл.Открыть("Полный путь к файлу");
    печТаблица=СоздатьОбьект("Таблица");
    Для номСтроки=1 По текстфайл.КоличествоСтрок() Цикл
    печТаблица.Область(номстроки,1);
    КонецЦикла;
    печТаблица.Показать();
    
  6. TopicStarter Overlay
    krasdok
    Offline

    krasdok Опытный в 1С

    Регистрация:
    22 июн 2011
    Сообщения:
    130
    Симпатии:
    0
    Баллы:
    26
    Спасибо! А можно вставить в объект "Текст" в таблице из txt-файла текст наподобие как картинка целиком в объект "Картинка" вставляется
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Построчно.....
    Код:
    Процедура Сформировать()
    Таб=СоздатьОбъект("Таблица");
    Т=СоздатьОбъект("Текст");
    Т.Открыть("c:\1.111");
    Для к=1 По Т.КоличествоСтрок() Цикл
    Таб.Область("R"+к+"C1").Текст=Т.ПолучитьСтроку(к);
    КонецЦикла;
    Таб.Вывести();
    Таб.Показать();
    КонецПроцедуры
    
    или целиком
    Код:
    Процедура Сформировать()
    Таб=СоздатьОбъект("Таблица");
    Т=СоздатьОбъект("Текст");
    Т.Открыть("c:\1.111");
    стр="";
    Для к=1 По Т.КоличествоСтрок() Цикл
    стр=Стр+Т.ПолучитьСтроку(к)+Разделительстрок;
    КонецЦикла; 
    Таб.Область("R1C1").Текст=стр;
    Таб.Вывести();
    Таб.Показать();
    КонецПроцедуры
    

Поделиться этой страницей