[РЕШЕНО] Как вставить картинку в ФорматированныйДокумент

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем skv_79, 13 окт 2016.

  1. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    204
    Симпатии:
    3
    Баллы:
    29
    Здравствуйте!
    Сегодня весь вечер пытаюсь вставить картинку в форматированный документ. Нужно чтобы перед текстом, в самом верху была картинка. Весь вечер думаю как это сделать и понять не могу, уже пробовал и так, и этак. В СП прочитал про:
    Но либо уже к вечеру голова не соображает, либо еще что... вот что получилось, но это только текст, без картинки...
    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)  
        Начало = 0; Конец = 0; Вставка = Параметры.ФИО + Символы.ПС + Формат(Параметры.ДатаРождения, "ДЛФ=DD");
        Элементы.Документ.ПолучитьГраницыВыделения(Начало, Конец);
        ВставленныйТекст = Документ.Вставить(Начало, Вставка);
        ВставленныйТекст.Шрифт = Новый Шрифт(,,Истина);
        ВставленныйТекст = Документ.Вставить(ВставленныйТекст.ЗакладкаКонца, " ");
        ВставленныйТекст.Шрифт = Элементы.Документ.Шрифт;
        ЭтаФорма.ТекущийЭлемент = Элементы.Документ;
        Элементы.Документ.УстановитьГраницыВыделения(ВставленныйТекст.ЗакладкаКонца, ВставленныйТекст.ЗакладкаКонца);
    КонецПроцедуры
    Последнее редактирование модератором: 14 окт 2016
  2. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    304
    Симпатии:
    49
    Баллы:
    54
    Код:
    &НаКлиенте
    Процедура Картинка(Команда)
        Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);   
        Если Диалог.Выбрать() Тогда       
            ДобавитьКартинку(Диалог.ПолноеИмяФайла);       
        КонецЕсли;
    КонецПроцедуры
    
    &НаСервере
    Процедура ДобавитьКартинку(ПолноеИмяФайла)
        Документ.Добавить(ПолноеИмяФайла, Тип("КартинкаФорматированногоДокумента"));   
    КонецПроцедуры
    --- Объединение сообщений, 13 окт 2016 ---
    Обработка

    Вложения:

    nbIpKuH_BaH9I и skv_79 нравится это.
  3. TopicStarter Overlay
    skv_79
    Offline

    skv_79 Опытный в 1С

    Регистрация:
    10 июл 2013
    Сообщения:
    204
    Симпатии:
    3
    Баллы:
    29
    Благодарю!

Поделиться этой страницей