8.х Как в тонком клиенте сделать вывод на выбор док-та Excel?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем prog_22, 8 июл 2013.

  1. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Еще раз здравствуйте!

    Пишу обработку под тонкий клиент: она загружает данные из экселя в 1с

    На толстом все работает. Вот на тонком такая вещь:

    На форме никак не могу настроить выбор документа( скрин)

    Наверное где-то в настройках?

    Вот код

    Код:
    &НаКлиенте
    Процедура ИмяФайлаНачалоВыбора1(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл с данными";
    Диалог.ПолноеИмяФайла = "";
    Диалог.Фильтр = "Книга MS Excel (*.xls)|*.xls|";
    Если Диалог.Выбрать() Тогда
    ИмяФайла = Диалог.ПолноеИмяФайла;
    КонецЕсли;
    КонецПроцедуры
    
    Где "имя файла" должно быть три точки, т.е. выбор документа excel

    Простите за поспешность, нашел.

    Вложения:

  2. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Вот теперь другая проблема.. В поле "имя файла" выбор документа открывается, но при выборе файла эксель не сохраняется путь файла на форме, т.е. он его не видит. В толстом все нормально, а вот в тонком видимо как то по другому нужно..помогите!
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а вы как делаете? ошибку выдает или что? отладчик что вам смог подсказать?
  4. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Вообщем я переношу обработку с толстого на тонкий клиент. Все получилось, осталось лишь настроить выбор файла эксель , из которого будут загружаться данные в 1с.

    Код:
    &НаКлиенте
    Процедура ИмяФайлаНачалоВыбора1(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл с данными";
    Диалог.ПолноеИмяФайла = "";
    Диалог.Фильтр = "Книга MS Excel (*.xls)|*.xls|";
    Если Диалог.Выбрать() Тогда
    ИмяФайла = Диалог.ПолноеИмяФайла;
    КонецЕсли;
    КонецПроцедуры
    
    этот код, как сказал синтаксис помошник, работает в тонком клиенте, там даже пример почти такой же.

    Я сделал все так же как в толстом, в свойствах поля формы указал в "Начало выбора" мою процедуру. никаких ошибок не выдаёт при компилировании
  5. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Вот скрин. выбираю файл эксель, нажимаю открыть. но потом поле "имя файла" пустое, нет ссылки на документ.

    Вложения:

    • 22.jpg
      22.jpg
      Размер файла:
      105,7 КБ
      Просмотров:
      4
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ИмяФайла - это переменная или реквизит?
  7. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    реквизит
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    формы или обЪекта
  9. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    ну он присудствует и в форме и в объекте
  10. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    могу ошибаться, но наверное реквизиту обЪекта надо обрабщаться не на клиенте..
  11. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Вот скрин



    Когда ставлю &НаСервере

    то выдаёт ошибку "Тип не определен(ДиалогВыбораФайла)

    Вложения:

    • 222.jpg
      222.jpg
      Размер файла:
      90,3 КБ
      Просмотров:
      8
  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    диалога и не бует на сервере (его там показывать то некому). Попробуйте через Элементы.ИмяФайла = .....
  13. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    при выборе файла выдает ошибку " Поле объекта недоступно для записи(ИмяФайла)
  14. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    Где поставить право на запись поля объекта?
  15. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    если недоступно для записи, значит оно только лдя чтения доступно. Скорее всего надо еще указать, Элементы.ИмяФайла.Значение - но это лишь догадка, как в управляемом приложении действует - не могу сказать. Ну или запись реквизита обЪекта на сервере делать (вызывать процедуру, которая на сервере выполняться будет)
  16. TopicStarter Overlay
    prog_22
    Offline

    prog_22 Опытный в 1С

    Регистрация:
    31 окт 2012
    Сообщения:
    171
    Симпатии:
    0
    Баллы:
    26
    а можно пример как написать процедуру эту?
  17. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    попробуйте ОбЪект.ИмяФайла = ....

Поделиться этой страницей