8.х Как узнать проведен ли текущий документ

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем v0233, 22 фев 2011.

  1. TopicStarter Overlay
    v0233
    Offline

    v0233 Опытный в 1С

    Регистрация:
    23 авг 2010
    Сообщения:
    167
    Симпатии:
    0
    Баллы:
    26
    Добрый день. Подскажите такой глупый вопрос

    Как узнать проведен ли текущий документ?

    Код:
    Процедура ПередЗаписью
    Если ТекущийДокумент.Проведен=Истина Тогда 
    КонецЕсли;
    КонецПроцедуры;
    
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Чем Вас не устраивает код, приведенный Вами же?
  3. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Только что такое в вашем коде ТекущийДокумент?
    Если ПередЗаписью это обработчик формы документа или процедура модуля документа, то:
    Код:
    Если Проведен Тогда // или ЭтотОбъект.Проведен
    КонецЕсли;
    

Поделиться этой страницей