7.7 Как узнать, как отктрыт документ? Только просмотр или нет?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем klen, 7 ноя 2006.

  1. TopicStarter Overlay
    klen
    Offline

    klen

    Регистрация:
    25 окт 2006
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ПриОткрытии()
    // что писать?
    КонецПроцедуры 
    
  2. Prospero
    Offline

    Prospero Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    111
    Симпатии:
    0
    Баллы:
    26
    Может, имеется ввиду возможность или невозможность редактирования документов различными категориями сотрудников? Тогда, наверное, нуно делать проверку "ху из ху" и по результатам уже разрешить или запрещать редактирование...
  3. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Форма.ТолькоПросмотр()
    Возвращает:
    Текущее числовое значение режима редактирования формы (на момент до исполнения метода).
  4. TopicStarter Overlay
    klen
    Offline

    klen

    Регистрация:
    25 окт 2006
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Вот такая должна быть Процедура ПриОткрытии()
    Код:
    Процедура ПриОткрытии()
    
    ЗапрещенПросмотр = Форма.ТолькоПросмотр();   // определим, запрещено ли редактирование
    Форма.ТолькоПросмотр(ЗапрещенПросмотр);   // восстановим исходное состояние запрета редактирования формы
    
    Если ЗапрещенПросмотр = 1 Тогда      // проверяем состояние запрета редактирования в момент открытия формы
    // только просмотр
    Иначе
    // разрешено редактирование
    КонецЕсли;
    КонецПроцедуры 
    
    Всем большое спасибо. :unsure:

Поделиться этой страницей