7.7 Как удалить?

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем Bad_Boy, 9 ноя 2008.

  1. TopicStarter Overlay
    Bad_Boy
    Offline

    Bad_Boy

    Регистрация:
    3 окт 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Привет всем! Меня интересует вопрос: как удалить накладные, цены, контрагентов, но чтобы наименования в номенклатуре остались? (Меня интересует массовое удаление по заданному критерию, а не удаление поштучно)
    :unsure:
  2. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    посмотри на диске ИТС или на инфостарте.


    или вот, тоже работает
    Код:
    Процедура Сформировать()
    Докум=СоздатьОбъект("Документ");       //здесь указываем конкретный докум, например "Документ.РасходнаяНакладная"
    ПодчиненныйДокум=СоздатьОбъект("Документ");
    Докум.ВыбратьДокументы(НачДата,КонДата);
    Пока Докум.ПолучитьДокумент() = 1 Цикл
    Докум.СделатьНеПроведенным();
    ПодчиненныйДокум.ВыбратьПодчиненныеДокументы(,,Докум);
    Пока ПодчиненныйДокум.ПолучитьДокумент()=1 Цикл
    Сообщить("Помечен на удаление  "+ПодчиненныйДокум.ТекущийДокумент()+"   Дата   "+ПодчиненныйДокум.ДатаДок);
    ПодчиненныйДокум.СделатьНеПроведенным();
    ПодчиненныйДокум.Удалить(0);
    КонецЦикла;
    Сообщить("Помечен на удаление  "+Докум.ТекущийДокумент()+"   Дата   "+Докум.ДатаДок);
    Докум.Удалить(0);
    КонецЦикла;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    Bad_Boy
    Offline

    Bad_Boy

    Регистрация:
    3 окт 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Спасибо, попробую разобраться. А этот код который ты написал это где надо размещать? :)
  4. bob
    Offline

    bob Опытный в 1С

    Регистрация:
    7 май 2008
    Сообщения:
    386
    Симпатии:
    0
    Баллы:
    26
    например как внешнюю обработку
  5. TopicStarter Overlay
    Bad_Boy
    Offline

    Bad_Boy

    Регистрация:
    3 окт 2007
    Сообщения:
    24
    Симпатии:
    0
    Баллы:
    1
    Ок, спасибо
Похожие темы
  1. russlix
    Ответов:
    1
    Просмотров:
    1.080
  2. samec01
    Ответов:
    19
    Просмотров:
    3.845
Загрузка...

Поделиться этой страницей