8.х Как удалить запись из регистра сведений?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем MaximKh, 28 окт 2010.

  1. TopicStarter Overlay
    MaximKh
    Offline

    MaximKh Опытный в 1С

    Регистрация:
    19 апр 2010
    Сообщения:
    93
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Делаю обработку для чистки регистра сведений ШтатноеРасписание по организациям, которые уже давно не используются...
    Код:
    НаборЗаписей = РегистрыСведений.ШтатноеРасписаниеОрганизаций.СоздатьНаборЗаписей();
    НаборЗаписей.Прочитать();
    
    Для Каждого Запись ИЗ НаборЗаписей Цикл
    Если Запись.ПодразделениеОрганизации.Владелец = Организация Тогда
    Сообщить ("Подразделение входит в организацию: " + Организация);
    ШР = Запись.ПолучитьОбъект();
    //ШР.удалить(); ??????????????
    ОбработкаПрерыванияПользователя();
    КонецЕсли;
    КонецЦикла;
    
    
    Как программно удалить найденную запись? Какие идеи?

    ШР = Запись.ПолучитьОбъект тоже не работает... Забыл исправить )))
  2. Itsys
    Offline

    Itsys Опытный в 1С

    Регистрация:
    3 янв 2010
    Сообщения:
    1.394
    Симпатии:
    0
    Баллы:
    26
    Общий алгоритм такой: Запросом выбираете все ненужные подразделения, выгружаете их в список значений, создаете набор записей, устанавливаете в нем отбор по полученному списку и записываете.
  3. KoD
    Offline

    KoD

    Регистрация:
    23 сен 2010
    Сообщения:
    26
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Организация = Справочники.Организации.НайтиПоКоду("000000001");
    НаборЗаписей = РегистрыСведений.ШтатноеРасписаниеОрганизаций.Выбрать();
    
    Пока НаборЗаписей.Следующий() Цикл 	
    Если НаборЗаписей.ПодразделениеОрганизации.Владелец = Организация Тогда
    Сообщить ("Подразделение входит в организацию: " + Организация);
    Удаление = НаборЗаписей.ПолучитьМенеджерЗаписи();
    Удаление.Удалить();
    ОбработкаПрерыванияПользователя();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    

Поделиться этой страницей