7.7 Как удалить документ который внес изменения в периодический реквизит

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 5 апр 2017.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Удаляются периодические значения но нужно еще удалить документ
    Последнее редактирование: 6 апр 2017
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    см метод ТекущийДокумент(). Если не пустой - это ссылка на документ который сделал движение.
    Almius нравится это.
  3. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Посмотрел, док есть А как его пометить на удаление?
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    Док=СоздатьОбъект("Документ");
    Если Док.НайтиДокумент(Период.ТекущийДокумент())=1 Тогда
    Док.Удалить(0);
    КонецЕсли;
  5. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Если Док.НайтиДокумент(Период.ТекущийДокумент())=1 Тогда не допустимая операция
    Последнее редактирование: 6 апр 2017
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    А где проверка что ссылка не пустая?
  7. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    .
    Последнее редактирование: 6 апр 2017
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    Если ПустоеЗначение(Период.ТекущийДокумент())=0 Тогда
    Док=СоздатьОбъект("Документ");
    Если Док.НайтиДокумент(Период.ТекущийДокумент())=1 Тогда
    Док.Удалить(0);
    КонецЕсли;
    КонецЕсли;
    Almius нравится это.
  9. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    39
    Симпатии:
    0
    Баллы:
    1
    Сделал так, заработало. Спасибо огромное :)


    Если ПустоеЗначение(Период.Значение.ТекущийДокумент())=0 Тогда
    Док=СоздатьОбъект("Документ");
    Если Док.НайтиДокумент(Период.Значение.ТекущийДокумент())=1 Тогда
    Док.Удалить(0);
    КонецЕсли;
    КонецЕсли;
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    Не за что.. Обращайтесь