8.х Как убрать одно значение из вариантов обеспечения

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Silapil, 21 авг 2018.

  1. TopicStarter Overlay
    Silapil
    Offline

    Silapil Опытный в 1С

    Регистрация:
    25 авг 2017
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    В очередной раз прошу вашей помощи. В заказе клиента во вкладке "Товары" при изменении варианта обеспечения потребности (Действие), иногда в списке фигурирует "Резервировать к дате".. Часто менеджеры выбирают этот пункт ВМЕСТО пункта "Резервировать" и соответственно товар не резервируется на складе. Подскажите пожалуйста, как убрать/скрыть это в списке вариантов? В конфигурации долго курил-искал, но так и не нашёл((
    --- Объединение сообщений, 21 авг 2018 ---
    УТ11.3 файловая проф
  2. Briz
    Offline

    Briz Опытный в 1С

    Регистрация:
    9 апр 2013
    Сообщения:
    66
    Симпатии:
    6
    Баллы:
    29
    (0) в параметрах выбора реквизита табличной части укажи ТОЛЬКО нужные тебе значения
  3. TopicStarter Overlay
    Silapil
    Offline

    Silapil Опытный в 1С

    Регистрация:
    25 авг 2017
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Там вообще пусто((
    upload_2018-8-21_16-43-15.png
  4. Briz
    Offline

    Briz Опытный в 1С

    Регистрация:
    9 апр 2013
    Сообщения:
    66
    Симпатии:
    6
    Баллы:
    29
    (3) я и сказал - "укажи"...
  5. TopicStarter Overlay
    Silapil
    Offline

    Silapil Опытный в 1С

    Регистрация:
    25 авг 2017
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Абсурд. Как это "заработает"? Это же будут просто значения. Может ты меня не понял - я про этот список:
    upload_2018-8-21_17-42-21.png
    --- Объединение сообщений, 21 авг 2018 ---
    В общем модуле нашёл это:

    Если ЗначениеЗаполнено(СтрокаТаблицы.ДатаДоступности) Тогда // добавляется действие "Резервировать к дате"

    НоваяСтрока.ВариантОбеспечения = ВариантИзЗаказов;
    НоваяСтрока.ДатаОтгрузки = СтрокаТаблицы.ДатаДоступности;

    Иначе


    Но почему-то ничего не меняется, когда комментирую((
  6. Briz
    Offline

    Briz Опытный в 1С

    Регистрация:
    9 апр 2013
    Сообщения:
    66
    Симпатии:
    6
    Баллы:
    29
    :)
    (5)да... учиться ВСЁ ЖЕ придётся
  7. TopicStarter Overlay
    Silapil
    Offline

    Silapil Опытный в 1С

    Регистрация:
    25 авг 2017
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Ради одной мелочи время тратить - изучать? Смысл?
  8. TopicStarter Overlay
    Silapil
    Offline

    Silapil Опытный в 1С

    Регистрация:
    25 авг 2017
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Помогите - не могу разобраться.. Нашёл, как убрать ненужные строки - просто комментирую это:

    Код:
    //Если ДобавлятьИзЗаказов И ЗначениеЗаполнено(Строка.ДатаДоступности) Тогда
    
         //   НоваяСтрока = Таблица.Добавить();
         //   НоваяСтрока.ВариантОбеспечения = Перечисления.ВариантыОбеспечения.ИзЗаказов;
         //   ЗаполнитьЗначенияСвойств(НоваяСтрока, Строка, "Количество, Склад, ДатаДоступности");
    
         //КонецЕсли;
    Пункты успешно исчезают, но следом за ними внизу формы пропадает ожидаемое количество товаров. Тоесть пишется "Ожидается: 0". Хотя до этого писалось другое количество, которое заказано у поставщика.
    upload_2018-8-23_13-46-42.png

    Помогите пожалуйста..

    Вот ещё кусок кода, который остатки "делает"))

    Код:
    &НаКлиенте
    Процедура ОбновитьНадписьОбеспечено()
    
       Если Элементы.СтраницыДействия.ТекущаяСтраница <> Элементы.СтраницаДействия Тогда
    
         Если ТипНоменклатуры = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Работа") Тогда
    
           Шаблон = НСтр("ru = 'Обеспечено - %1 %2, не обеспечено - %3 %4.'");
           НадписьОбеспечено = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
             Шаблон,
             КоличествоПодНазначение, ЕдиницаИзмерения,
             Макс(КоличествоТребуется - КоличествоПодНазначение, 0), ЕдиницаИзмерения);
    
         Иначе
    
           Шаблон = НСтр("ru = '%1 - %2 %3, ожидается - %4 %5, не обеспечено - %6 %7.'");
    
           НадписьОбеспечено = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
             Шаблон,
             ШаблонПоступилоПод,
             КоличествоОтгрузитьОбособленно,
             ЕдиницаИзмерения,
             КоличествоПодНазначение - КоличествоОтгрузитьОбособленно,
             ЕдиницаИзмерения,
             Макс(КоличествоТребуется - КоличествоПодНазначение, 0),
             ЕдиницаИзмерения);
    
         КонецЕсли;
    
       Иначе
    
         ТекущаяСтрока = Элементы.Действия.ТекущиеДанные;
    
         Если ТекущаяСтрока = Неопределено
           Или ТипНоменклатуры = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Работа")
           Или ТипНоменклатуры = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга") Тогда
    
             НадписьОбеспечено = "";
    
           Иначе
    
             КоличествоОтгрузить = 0;
             КоличествоОжидается = 0;
             Для каждого СтрокаТаблицы Из Действия Цикл
     
               Если СтрокаТаблицы.Склад = ТекущаяСтрока.Склад Тогда
       
                 Если СтрокаТаблицы.ВариантОбеспечения = ПредопределенноеЗначение("Перечисление.ВариантыОбеспечения.Отгрузить")
                   Или СтрокаТаблицы.ВариантОбеспечения = ПредопределенноеЗначение("Перечисление.ВариантыОбеспечения.СоСклада") Тогда
                   КоличествоОтгрузить = СтрокаТаблицы.КоличествоДоступно;
                 КонецЕсли;
       
                 Если СтрокаТаблицы.ВариантОбеспечения = ПредопределенноеЗначение("Перечисление.ВариантыОбеспечения.ИзЗаказов") Тогда
                   КоличествоОжидается = Макс(КоличествоОжидается, СтрокаТаблицы.КоличествоДоступно);
                 КонецЕсли;
       
               КонецЕсли;
     
             КонецЦикла;
             КоличествоОжидается = Макс(КоличествоОжидается - КоличествоОтгрузить, 0);
    
             НадписьОбеспечено = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
               НСтр("ru = 'Доступно сейчас - %1 %2, ожидается - %3 %4.'"),
               КоличествоОтгрузить, ЕдиницаИзмерения,
               КоличествоОжидается, ЕдиницаИзмерения);
    
           КонецЕсли;
    
       КонецЕсли;
    
    КонецПроцедуры
    Находится это всё в "Перечисление ВариантыОбеспечения: ВыборВариантаОбеспечения"
    Последнее редактирование: 23 авг 2018

Поделиться этой страницей