7.7 Как связать плательщика и товар который ему принадлежит в данный промежуток времени

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kompac, 7 июл 2010.

  1. TopicStarter Overlay
    kompac
    Offline

    kompac

    Регистрация:
    30 дек 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Как связать плательщика и товар который ему принадлежит в данный промежуток времени.

    и вывести отчетик

    название плательщика 1 общее кол-во штук(3) кг(30) сумма(635)
    товар1 1 14,4 315
    товар2 2 15,5 320

    название плательщика2 и так до последнего плательщика
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Какая у вас конфигурация?
  4. TopicStarter Overlay
    kompac
    Offline

    kompac

    Регистрация:
    30 дек 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Тороговля+Склад 9.2
  5. TopicStarter Overlay
    kompac
    Offline

    kompac

    Регистрация:
    30 дек 2008
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    Все нужно сделать во внешнем отчете.
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Я так понимаю нужен отчет по отгруженному товару за период.
    Все делается простым запросом.
    Обратите внимание, что в единичах измерения должен быть
    проставлен вес
    Код:
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = 
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Контрагент = Документ.Реализация.Контрагент;
    |Номенклатура = Документ.Реализация.Номенклатура;
    |Вес = Документ.Реализация.Единица.Вес;
    |Коэффициент = Документ.Реализация.Коэффициент;
    |Количество = Документ.Реализация.Количество;
    |Сумма = Документ.Реализация.Сумма;
    |Функция ВесСумма = Сумма(Вес*Коэффициент);
    |Функция КоличествоСумма = Сумма(Количество*Коэффициент);
    |Функция СуммаСумма = Сумма(Сумма);
    |Группировка Контрагент без групп;
    |Группировка Номенклатура без групп;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Контрагент
    Таб.ВывестиСекцию("Контрагент");
    Пока Запрос.Группировка(2) = 1 Цикл
    // Заполнение полей Номенклатура
    Таб.ВывестиСекцию("Номенклатура");
    КонецЦикла;
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    
    
Похожие темы
  1. Kirya
    Ответов:
    8
    Просмотров:
    3.836
  2. Fominv
    Ответов:
    4
    Просмотров:
    2.988
  3. Nik02071
    Ответов:
    6
    Просмотров:
    620
  4. strangless
    Ответов:
    2
    Просмотров:
    1.492
  5. Virgiliy
    Ответов:
    17
    Просмотров:
    1.099
Загрузка...

Поделиться этой страницей