8.х Как сразу провести и распечатать ЧекККМ в УТ 10.3?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dimka77, 29 авг 2010.

  1. TopicStarter Overlay
    Dimka77
    Offline

    Dimka77 Опытный в 1С

    Регистрация:
    6 июн 2009
    Сообщения:
    279
    Симпатии:
    0
    Баллы:
    26
    В форме документа "ЧекККМ" есть кнопка "Чек" при нажатии на которую появляется печатная форма ЧекаККМ, для печати на принтере, это возможно только для проведенного документа.
    Как сделать так, чтоб при нажатии на кнопку "Чек" проводился документ и сразу выводился на принтер?
    Пробовал вставлять
    Код:
    Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Оперативный);
    
    в "Процедура ОсновныеДействияФормыДействиеПечать(Кнопка)". Документ проводится, но при этом пользователи, с ограниченными правами, могут править, проведенными таким образом, документы, ну и макет чека все равно выводится на экран и приходится опять жать на кнопку печати.
    Есть идеи как решить задачу?
  2. TopicStarter Overlay
    Dimka77
    Offline

    Dimka77 Опытный в 1С

    Регистрация:
    6 июн 2009
    Сообщения:
    279
    Симпатии:
    0
    Баллы:
    26
    Ответ найден! Создал новую кнопку на форме документа "Быстрая печать", а в её действие засунул такой код:
    Код:
    Процедура ОсновныеДействияФормыБыстраяПечать(Кнопка)
    Перем Ответ;
    Перем Отказ;
    Если ЭлементыФормы.СуммаОплаты.Значение=0 Тогда
    Если ПереключательОплатаПростая Тогда
    СуммаОплаты = Товары.Итог("Сумма");
    ПриИзмененииСуммыОплаты();
    Иначе
    Предупреждение("Оплата редактируется в списке!");
    КонецЕсли;
    КонецЕсли;
    Если ПровестиИРаспечататьЧек(Ответ, Отказ, ЭтаФорма) Тогда
    Печать("Чек",  1, Истина);
    Закрыть();
    Иначе
    Предупреждение(?(Отказ, "Возможны расхождения ИБ и ленты ФР! ", "") + Ответ);
    КонецЕсли;
    КонецПроцедуры
    
    
    Теперь все работает, и если сумма оплаты не указана, то она автоматически подставляется исходя из суммы покупки. Вот! :unsure:

Поделиться этой страницей