[РЕШЕНО] Как спозиционироваться на искомой строке дерева?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Bkmz, 14 ноя 2017 в 13:40.

  1. TopicStarter Overlay
    Bkmz
    Offline

    Bkmz Опытный в 1С

    Регистрация:
    6 июл 2013
    Сообщения:
    331
    Симпатии:
    11
    Баллы:
    29
    Есть дерево на форме. Как можно сделать поиск по дереву? чтобы нажав на кнопку найти на форме введенное в поле значение?
  2. TopicStarter Overlay
    Bkmz
    Offline

    Bkmz Опытный в 1С

    Регистрация:
    6 июл 2013
    Сообщения:
    331
    Симпатии:
    11
    Баллы:
    29
    Для управляемых форм, на втором уровне

    Код:
    &НаКлиенте
    Процедура НайтиОС()
        Для каждого Стр Из ЭтаФорма.ОсновныеСредстваМОЛ.ПолучитьЭлементы() Цикл
            ОсновныеСредства = Стр.ПолучитьЭлементы();
            Для каждого СтрОС Из ОсновныеСредства Цикл
                Если СтрОС.ОСиМОЛ = ЭтаФорма.ПоискОсновногоСредства Тогда
                    Элементы.ОсновныеСредстваМОЛ.ТекущаяСтрока = СтрОС.ПолучитьИдентификатор();
                КонецЕсли;
            КонецЦикла;
        КонецЦикла;
    КонецПроцедуры
    

Поделиться этой страницей